1011 World Cup Betting (20 分)

1. 题目

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

2. 题意

题目一大段的,其实就是找出三个数中的最大值,最大值对应的输赢情况需要输出出来,三组数据的最大值需要相乘后代入题目给的公式即可。

3. 思路——简单模拟

三组数据,每组数据三个数,需要找出三个数中的最大值,if条件句判断其中一个数均大于或等于其余两个数即为最大值。三组数的最大值找到并输出最大值对应的输赢情况,并将三个最大值相乘后的值代入公式即可。

4. 代码

#include <iostream>

using namespace std;
    
int main()
{
    double sum = 1;
    double x, y, z;
    string s = "";
    for (int i = 0; i < 3; ++i)
    {
        cin >> x >> y >> z;
        // 判断三个数中的最大值,最大值与sum相乘,并输出最大值对应的情况 
        if (x >= y && x >= z) sum *= x, s += "W ";
        else if (y >= x && y >= z) sum *= y, s += "T ";
        else sum *= z, s += "L ";
    }
    cout << s;
    // 根据题目所给公式计算即可 
    printf("%.2lf", (sum * 0.65 - 1) * 2);
    return 0;
}
原文地址:https://www.cnblogs.com/vanishzeng/p/15478009.html