2-括号配对问题

括号配对问题

时间限制:3000 ms  |  内存限制:65535 KB
难度:3
 
描述
现在,有一行括号序列,请你检查这行括号是否配对。
 
输入
第一行输入一个数N(0<N<=100),表示有N组测试数据。后面的N行输入多组输入数据,每组输入数据都是一个字符串S(S的长度小于10000,且S不是空串),测试数据组数少于5组。数据保证S中只含有"[","]","(",")"四种字符
输出
每组输入数据的输出占一行,如果该字符串中所含的括号是配对的,则输出Yes,如果不配对则输出No
样例输入
3
[(])
(])
([[]()])
样例输出
No
No
Yes
#include<iostream>
#include<cstdio>
#include<stack>
#include<algorithm>
using namespace std;
stack <char> s;
int main()
{
    int n;
    cin>>n;
    getchar();
    while(n--)
    {
        while(!s.empty()) s.pop();
        int flag=1;
        char temp;
        while(1)
        {
            temp=getchar();
            if(temp=='
') break;
            else if(temp=='['||temp=='(') s.push(temp);
            else if(temp==']')
            {
                if(!s.empty()&&s.top()=='[') s.pop();
                else flag=0;
            }
            else if(temp==')')
            {
                if(!s.empty()&&s.top()=='(') s.pop();
                else flag=0;
            }
        }
        if(s.empty()&&flag) cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/tt-t/p/5022596.html