[codeup] 1126 看电视

题目描述

暑假到了,小明终于可以开心的看电视了。但是小明喜欢的节目太多了,他希望尽量多的看到完整的节目。
现在他把他喜欢的电视节目的转播时间表给你,你能帮他合理安排吗?

输入

输入包含多组测试数据。每组输入的第一行是一个整数n(n<=100),表示小明喜欢的节目的总数。
接下来n行,每行输入两个整数si和ei(1<=i<=n),表示第i个节目的开始和结束时间,为了简化问题,每个时间都用一个正整数表示。
当n=0时,输入结束。

输出

对于每组输入,输出能完整看到的电视节目的个数。

样例输入

12
1 3
3 4
0 7
3 8
15 19
15 20
10 15
8 18
6 12
5 10
4 14
2 9
0

样例输出

5

思路

贪心,找出最大不相交区间问题。把所有区间按左端点x从大到小排序,如果去除区间包含的情况,那么一定有y1>y2>...>yn成立,每次总是优先选择左端点最大的区间,或者总是优先选择右端点最小的区间。

代码

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 100;
struct Inteval
{
	int x;
	int y;
} inteval[maxn];

bool cmp(Inteval a, Inteval b)
{
	if (a.x != b.x)
		return a.x > b.x;
	else
		return a.y < b.y;
}

int main()
{
	int n;
	while (scanf("%d", &n) && n != 0) {
		for (int i = 0; i < n; i++)
			cin >> inteval[i].x >> inteval[i].y;
		sort(inteval, inteval + n, cmp);
		int ans = 1, lastx = inteval[0].x;
		for (int i = 1; i < n; i++) {
			if (inteval[i].y <= lastx) {
				lastx = inteval[i].x;
				ans++;
			}
		}
		cout << ans << endl;
	}

	return 0;
}
原文地址:https://www.cnblogs.com/trav/p/10386372.html