hdoj 2122 Ice_cream’s world III

并查集+最小生成树

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1121    Accepted Submission(s): 365


Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 
Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 
Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 
Sample Input
2 1
0 1 10
 
 
4 0
 
Sample Output
10
 
impossible
 
kruskal算法
 
#include<stdio.h>
#include<algorithm>
using namespace std;
int set[1100];
struct record
{
	int beg;
	int end;
	int money;
}s[11000];
int find(int fa)
{
	int ch=fa;
	int t;
	while(fa!=set[fa])
	fa=set[fa];
	while(ch!=fa)
	{
		t=set[ch];
		set[ch]=fa;
		ch=t;
	}
	return fa;
}
void mix(int x,int y)
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if(fx!=fy)
	set[fx]=fy;
}
bool cmp(record a,record b)
{
	return a.money<b.money;
}
int main()
{
	int n,m,j,i,sum,village,road;
	while(scanf("%d%d",&village,&road)!=EOF)
	{
		
		for(i=0;i<village;i++)
		set[i]=i;
		for(i=0;i<road;i++)
		{
			scanf("%d%d%d",&s[i].beg,&s[i].end,&s[i].money);
		}
		sort(s,s+road,cmp);
		sum=0;
		for(i=0;i<road;i++)
		{
		    if(find(s[i].beg)!=find(s[i].end))
		    {
		    	mix(s[i].beg,s[i].end);
		    	sum+=s[i].money;
		    }
		}
		m=0;
		for(i=0;i<village;i++)
		{
			if(set[i]==i)
			m++;
		}
		if(m>1)
		printf("impossible

");
		else
		printf("%d

",sum);
	}
	return 0;
}

  

原文地址:https://www.cnblogs.com/tonghao/p/4481673.html