HDU1319 POJ1595 UVA406 UVALive5490 ZOJ1312 Prime Cuts【素数筛选+打表】

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 11505   Accepted: 4373

Description

A prime number is a counting number (1, 2, 3, ...) that is evenly divisible only by 1 and itself. In this problem you are to write a program that will cut some number of prime numbers from the list of prime numbers between (and including) 1 and N. Your program will read in a number N; determine the list of prime numbers between 1 and N; and print the C*2 prime numbers from the center of the list if there are an even number of prime numbers or (C*2)-1 prime numbers from the center of the list if there are an odd number of prime numbers in the list.

Input

Each input set will be on a line by itself and will consist of 2 numbers. The first number (1 <= N <= 1000) is the maximum number in the complete list of prime numbers between 1 and N. The second number (1 <= C <= N) defines the C*2 prime numbers to be printed from the center of the list if the length of the list is even; or the (C*2)-1 numbers to be printed from the center of the list if the length of the list is odd.

Output

For each input set, you should print the number N beginning in column 1 followed by a space, then by the number C, then by a colon (:), and then by the center numbers from the list of prime numbers as defined above. If the size of the center list exceeds the limits of the list of prime numbers between 1 and N, the list of prime numbers between 1 and N (inclusive) should be printed. Each number from the center of the list should be preceded by exactly one blank. Each line of output should be followed by a blank line. Hence, your output should follow the exact format shown in the sample output.

Sample Input

21 2
18 2
18 18
100 7

Sample Output

21 2: 5 7 11

18 2: 3 5 7 11

18 18: 1 2 3 5 7 11 13 17

100 7: 13 17 19 23 29 31 37 41 43 47 53 59 61 67

Source




Regionals 1996 >> North America - South Central USA


问题链接HDU1319 POJ1595 UVA406 UVALive5490 ZOJ1312 Prime Cuts

问题描述参见上文。

问题分析这是一个比较简单的问题。其关键是需要读懂题意,使用素数筛选法打表,然后进行输出即可。

需要注意的点如下:

1.题目中所说的素数并不是真正的素数,包括1;

2.需要读懂题意,对于输入的n和c,如果1到n之间有偶数个素数则打印2c个数,奇数个素数则打印2c-1个数;

3.打印的数是所有素数中位于中间位置的那些数。

事先还是要做一点功课的,计算一下1到1000之间有多少个素数,避免数组空间过大或过小。

另外,题目虽然说n<=100,但是,至少需要算一个比1000大的素数,以便统计小于n的素数的个数。

程序说明本程序逻辑清晰易懂,计算过程参见程序注释。


AC的C++语言程序如下:

/* HDU1319 POJ1595 UVA406 UVALive5490 ZOJ1312 Prime Cuts */

#include <iostream>
#include <math.h>
#include <stdio.h>

using namespace std;

#define MAXN 1050

bool isprime[MAXN+1];
int prime[200];

// 修正的Eratosthenes筛选法,根据题意包含1(并非全是素数)
void sieveofe(bool isprime[], int prime[], int n)
{
    int i, j;

    isprime[0] = false;
    isprime[1] = true;
    isprime[2] = true;

    // 初始化
    for(i=3; i<=n; i++) {
        isprime[i++] = true;
        isprime[i] = false;
    }
    int max = sqrt(n);
    for(i=3; i<=max; i++){
        if(isprime[i]) {
            for(j=i+i; j < n; j+=i)    //进行筛选
                isprime[j] = false;
        }
    }

    // 将素数放数组prime中,包含1
    prime[0] = 1;
    prime[1] = 2;
    j = 2;
    for(i=3; i<=n; i+=2)
        if(isprime[i])
            prime[j++] = i;
}

int main()
{
    // 筛选素数
    sieveofe(isprime, prime, MAXN);

    int n, c, count, i;
    int printcount, start, end;

    // 循环处理输入
    while(~scanf("%d%d",&n,&c)) {
        printf("%d %d:", n, c);

        // 统计素数个数
        count = 0;
        i = 0;
        while(prime[i++] <= n)
            count++;

        // 计算打印数据的个数
        if(count % 2 == 0) {
            printcount = 2 * c;
        } else {
            printcount = 2 * c -1;
        }

        // 计算数据的起始与终止位置
        if(printcount >= count) {
            start = 0;
            end = count - 1;
        } else {
            start = (count - printcount) / 2;
            end = start + printcount - 1;
        }

        // 打印结果
        for(i=start; i<=end; i++)
            printf(" %d", prime[i]);
        printf("

");
    }

    return 0;
}



原文地址:https://www.cnblogs.com/tigerisland/p/7564872.html