NUC1003 Hangover

Hangover

时间限制: 1000ms 内存限制: 65536KB

问题描述

    How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We are assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.

hangover.jpg

输入描述

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

输出描述

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

样例输入
1.00
3.71
0.04
5.19
0.00
样例输出
3 card(s)
61 card(s)
1 card(s)
273 card(s)
来源
{Mid-Central USA 2001}


问题分析:

这个题与《POJ1003 UVALive2294 HDU1056 ZOJ1045 Hangover》完全相同,代码直接拿过来用就AC了。

程序说明:

参见参考链接。

参考链接:POJ1003 UVALive2294 HDU1056 ZOJ1045 Hangover

题记:

程序写多了,似曾相识的也就多了。


AC的C++程序如下:

/* POJ1003 UVALive2294 HDU1056 ZOJ1045 Hangover */  
  
#include <iostream>  
#include <cstdio>  
  
using namespace std;  
  
const double one = 1.0;  
  
int main()  
{  
    double len, sum, d;  
    int i;  
  
    while((cin >> len) && len != 0.00) {  
        i = 1;  
  
        d = 2.0;  
        sum = one / d;  
        while(sum < len) {  
            d += 1.0;  
            sum += (one / d);  
            i++;  
        }  
  
        cout << i << " card(s)" << endl;  
    }  
  
    return 0;  
} 














原文地址:https://www.cnblogs.com/tigerisland/p/7563785.html