UVALive2287 POJ1047 HDU1313 ZOJ1073 Round and Round We Go【大数+数学计算】

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 12934   Accepted: 6050

Description

A cyclic number is an integer n digits in length which, when multiplied by any integer from 1 to n, yields a"cycle"of the digits of the original number. That is, if you consider the number after the last digit to "wrap around"back to the first digit, the sequence of digits in both numbers will be the same, though they may start at different positions.For example, the number 142857 is cyclic, as illustrated by the following table: 
142857 *1 = 142857 
142857 *2 = 285714 
142857 *3 = 428571 
142857 *4 = 571428 
142857 *5 = 714285 
142857 *6 = 857142 

Input

Write a program which will determine whether or not numbers are cyclic. The input file is a list of integers from 2 to 60 digits in length. (Note that preceding zeros should not be removed, they are considered part of the number and count in determining n. Thus, "01"is a two-digit number, distinct from "1" which is a one-digit number.)

Output

For each input integer, write a line in the output indicating whether or not it is cyclic.

Sample Input

142857
142856
142858
01
0588235294117647

Sample Output

142857 is cyclic
142856 is not cyclic
142858 is not cyclic
01 is not cyclic
0588235294117647 is cyclic

Source



Regionals 2001 >> North America - Greater NY


问题链接UVALive2287 POJ1047 HDU1313 ZOJ1073 Round and Round We Go

问题简述:参见上文

问题分析

这个问题可以用模拟的方法来解决,但是计算量大一些。用数学计算的方法来解决,则比较简洁。

一个数如果乘以其位数加上1,结果为全9则为循环数,否则不为循环数。

程序说明(略)

参考链接:(略)

题记(略)


AC的C++语言程序如下:

/* UVALive2287 POJ1047 HDU1313 ZOJ1073 Round and Round We Go */

#include <iostream>
#include <string.h>

using namespace std;

const int BASE10 = 10;
const int N = 60;
int a[N+10];

int main()
{
    string s;

    while(cin >> s) {
        memset(a, 0, sizeof(a));

        int len = s.length();
        int k=0, left=0;
        bool flag = true;
        for(int i=len-1; i>=0; i--, k++) {
            int digit = (s[i] - '0') * (len + 1) + left;
            a[k] = digit % BASE10;
            left = digit / BASE10;

            if(a[k] != 9) {
                flag = false;
                break;
            }
        }

        while(flag && left) {
            a[k] = left % BASE10;
            left /= BASE10;

            if(a[k] != 9) {
                flag = false;
                break;
            }

            k++;
        }

        cout << s << (flag ? " is cyclic" : " is not cyclic") << endl;
    }

    return 0;
}




原文地址:https://www.cnblogs.com/tigerisland/p/7563686.html