UVA10391 ZOJ1825 Compound Words【SET+暴力】

Compound Words

Time Limit: 5 Seconds      Memory Limit: 32768 KB

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.


Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.


Output

Your output should contain all the compound words, one per line, in alphabetical order.


Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra


Sample Output

alien
newborn


Source: University of Waterloo Local Contest 1996.09.28



问题链接UVA10391 ZOJ1825 Compound Words

题意简述一堆按照字典序排好的字符串,问有多少字符串是由其它两个字符串组成,输出这些字符串。

问题分析

采用穷举法来解决,数据规模不大就没有问题了。

将所有单词放入字符串集合中。

对所有单词s,将其分为所有可能的两个字符串t1和t2(s=t1+t2),查一下t1和t2是否都在集合中即可。

程序说明:(略)


AC的C++语言程序如下:

/* UVA10391 ZOJ1825 Compound Words */

#include <iostream>
#include <string>
#include <set>

using namespace std;

int main()
{
    string s, t1, t2;
    set<string> sset;
    int len;

    while(cin >> s)
        sset.insert(s);

    for(set<string>::iterator iter=sset.begin(); iter!=sset.end(); iter++) {
        s = *iter;
        len = s.length();
        for(int i=0; i<len-1; i++) {
            t1 = s.substr(0, i + 1);
            t2 = s.substr(i + 1, len - 1);
            if(sset.find(t1) != sset.end() && sset.find(t2) != sset.end()) {
                cout << s << endl;
                break;
            }
        }
    }

    return 0;
}



原文地址:https://www.cnblogs.com/tigerisland/p/7563654.html