HDU1862 EXCEL排序【排序】

EXCEL排序

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19807    Accepted Submission(s): 7275

Problem Description
Excel可以对一组纪录按任意指定列排序。现请你编写程序实现类似功能。
Input
测试输入包含若干测试用例。每个测试用例的第1行包含两个整数 N (<=100000) 和 C,其中 N 是纪录的条数,C 是指定排序的列号。以下有 N 
行,每行包含一条学生纪录。每条学生纪录由学号(6位数字,同组测试中没有重复的学号)、姓名(不超过8位且不包含空格的字符串)、成绩(闭区间[0, 100]内的整数)组成,每个项目间用1个空格隔开。当读到 N=0 时,全部输入结束,相应的结果不要输出。
Output
对每个测试用例,首先输出1行“Case i:”,其中 i 是测试用例的编号(从1开始)。随后在 N 行中输出按要求排序后的结果,即:当 C=1 时,按学号递增排序;当 C=2时,按姓名的非递减字典序排序;当 C=3 
时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。
Sample Input
3 1 000007 James 85 000010 Amy 90 000001 Zoe 60 4 2 000007 James 85 000010 Amy 90 000001 Zoe 60 000002 James 98 4 3 000007 James 85 000010 Amy 90 000001 Zoe 60 000002 James 90 0 0
 
Sample Output
Case 1: 000001 Zoe 60 000007 James 85 000010 Amy 90 Case 2: 000010 Amy 90 000002 James 98 000007 James 85 000001 Zoe 60 Case 3: 000001 Zoe 60 000007 James 85 000002 James 90 000010 Amy 90
 
Source

问题链接HDU1862 EXCEL排序

问题简述参见上文。

问题分析:这是一个排序程序,一切都是套路。

程序说明:(略)

题记:程序就是要写得简洁。

AC的C++语言程序如下:

/* HDU1862 EXCEL排序 */

#include <iostream>
#include <algorithm>
#include <string.h>

using namespace std;

const int N = 100000;

struct _student {
    char id[10];
    char name[12];
    int score;
} student[N];

// 按学号排序
bool cmp1(_student x, _student y)
{
    return strcmp(x.id, y.id) < 0;
}

// 按姓名排序
bool cmp2(_student x,_student y)
{
    if(strcmp(x.name, y.name) < 0)
        return true;
    else if(strcmp(x.name, y.name) == 0)
        return strcmp(x.id, y.id) < 0;
    else
        return false;
}

// 按成绩排序
bool cmp3(_student x, _student y)
{
    if(x.score < y.score)
        return true;
    else if(x.score == y.score)
        return strcmp(x.id, y.id) < 0;
    else
        return false;
}

int main()
{
    int n, c, caseno = 0;

    while(cin >> n >> c && n) {
        for(int i=0; i<n; i++)
            cin >> student[i].id >> student[i].name >> student[i].score;

        cout << "Case " << ++caseno << ":" << endl;

        if(c == 1)
            sort(student, student + n, cmp1);
        else if(c == 2)
            sort(student, student + n, cmp2);
        else
            sort(student, student + n, cmp3);

        for(int i=0; i<n; i++)
            cout << student[i].id << " " << student[i].name << " " << student[i].score << endl;
    }

    return 0;
}





原文地址:https://www.cnblogs.com/tigerisland/p/7563597.html