洛谷P3146 [USACO16OPEN]248

P3146 [USACO16OPEN]248

题目描述

Bessie likes downloading games to play on her cell phone, even though she doesfind the small touch screen rather cumbersome to use with her large hooves.

She is particularly intrigued by the current game she is playing.The game starts with a sequence of NN positive integers (2 leq Nleq 2482N248), each in the range 1 ldots 40140. In one move, Bessie cantake two adjacent numbers with equal values and replace them a singlenumber of value one greater (e.g., she might replace two adjacent 7swith an 8). The goal is to maximize the value of the largest numberpresent in the sequence at the end of the game. Please help Bessiescore as highly as possible!

给定一个1*n的地图,在里面玩2048,每次可以合并相邻两个,问最大能合出多少

输入输出格式

输入格式:

The first line of input contains NN, and the next NN lines give the sequence

of NN numbers at the start of the game.

输出格式:

Please output the largest integer Bessie can generate.

输入输出样例

输入样例#1:
4
1
1
1
2
输出样例#1:
3

说明

In this example shown here, Bessie first merges the second and third 1s to

obtain the sequence 1 2 2, and then she merges the 2s into a 3. Note that it is

not optimal to join the first two 1s.

/*
    区间dp,f[i][j]表示区间 i-j 合并的最大值
    可以由f[i][k],f[k+1][j]转移过来,转移条件为f[i][k]==f[k+1][j] 
*/
#include<iostream>
#include<cstdio>
using namespace std;
#define maxn 300
int n,a[maxn],f[maxn][maxn],ans;
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d",&a[i]);
        f[i][i]=a[i];
    }
    for(int len=2;len<=n;len++){
        for(int l=1;l+len-1<=n;l++){
            int r=l+len-1;
            for(int k=l;k<=r;k++){
                if(f[l][k]==f[k+1][r]){
                    f[l][r]=max(max(f[k+1][r]+1,f[l][k]+1),f[l][r]);
                    ans=max(ans,f[l][r]);
                }
            }
        }
    }
    cout<<ans;
}
原文地址:https://www.cnblogs.com/thmyl/p/7603215.html