洛谷P3102 [USACO14FEB]秘密代码Secret Code

P3102 [USACO14FEB]秘密代码Secret Code

题目描述

Farmer John has secret message that he wants to hide from his cows; the message is a string of length at least 2 containing only the characters A..Z.

To encrypt his message, FJ applies a sequence of "operations" to it, where an operation applied to a string S first shortens S by removing either some (but not all) of the initial characters or some (but not all) of the final characters from S, after which the original string S is attached either at the beginning or end. For example, a single operation to the string ABC could result in eight possible strings:

AABC ABABC BCABC CABC ABCA ABCAB ABCBC ABCC Given the final encrypted string, please count the number of possible ways FJ could have produced this string using one or more repeated operations applied to some source string. Operations are treated as being distinct even if they give the same encryption of FJ's message. For example, there are four distinct separate ways to obtain AAA from AA.

Print your answer out modulo 2014.

农民约翰收到一条的消息,记该消息为长度至少为2,只由大写字母组成的字符串S,他通过一系列操作对S进行加密。

他的操作为,删除S的前面或者后面的若干个字符(但不删光整个S),并将剩下的部分连接到原字符串S的前面或者后面。如对于S=‘ABC’,共有8总可能的操作结果:

AABC

ABABC

BCABC

CABC

ABCA

ABCAB

ABCBC

ABCC

给出加密后的目标字符串,请计算共有多少种加密的方案。

对于同字符的字符串,加密方案不止一种,比如把AA加密成AAA,共有4种加密方案。将你的答案mod 2014后输出。

输入输出格式

输入格式:
  • Line 1: A single encrypted string of length at most 100.
输出格式:
  • Line 1: The number of ways FJ could have produced this string with one or more successive operations applied to some initial string of length at least 2, written out modulo 2014. If there are no such ways, output zero.

输入输出样例

输入样例#1:
ABABA 
输出样例#1:
8 

说明

Here are the different ways FJ could have produced ABABA:

1. Start with ABA -> AB+ABA 
2. Start with ABA -> ABA+BA 
3. Start with AB -> AB+A -> AB+ABA 
4. Start with AB -> AB+A -> ABA+BA 
5. Start with BA -> A+BA -> AB+ABA 
6. Start with BA -> A+BA -> ABA+BA 
7. Start with ABAB -> ABAB+A 
8. Start with BABA -> A+BABA 
#include<iostream>
#include<cstdio>
#include<cstring>
#define mod 23333333
using namespace std;
int ans;
char s[210],c[210],ss[210];
bool vis[23333337];
int Hash(char ch[],int len){
    int res=1;
    for(int i=1;i<=len;i++)
        res=(res*29+(ch[i]-'A'+1))%mod;
    return res;
}
int main(){
    scanf("%s",s+1);
    int len=strlen(s+1);
    vis[Hash(s,len)]=1;
    int now;
    for(int i=1;i<len;i++){//枚举剪下来的字符串的长度 
        //从前面剪 
        //接到后面 
        for(int k=1;k<=len;k++)ss[k]=s[k];
        for(int k=1;k<=i;k++)ss[len+k]=s[k];
        now=Hash(ss,len+i);
        if(!vis[now]){
            vis[now]=1;
            ans++;
            if(ans>=2014)ans-=2014;
        }
        //接到前面 
        for(int k=1;k<=i;k++)ss[k]=s[k];
        for(int k=1;k<=len;k++)ss[k+i]=s[k];
        now=Hash(ss,len+i);
        if(!vis[now]){
            vis[now]=1;
            ans++;if(ans>=2014)ans-=2014;
        }
        //从后面剪 
        //接到后面 
        for(int k=1;k<=len;k++)ss[k]=s[k];
        for(int k=1,j=len;k<=i;k++,j--)ss[len+k]=s[j];
        now=Hash(ss,len+i);
        if(!vis[now]){
            vis[now]=1;
            ans++;if(ans>=2014)ans-=2014;
        }
        //接到前面 
        for(int k=1,j=len;k<=i;k++,j--)ss[k]=s[j];
        for(int k=1;k<=len;k++)ss[k+i]=s[k];
        now=Hash(ss,len+i);
        if(!vis[now]){
            vis[now]=1;
            ans++;if(ans>=2014)ans-=2014;
        }
    }
    printf("%d",ans);
}
20分 不知道为啥写的哈希wa了
/*
    substr是C++语言函数,主要功能是复制子字符串,要求从指定位置开始,并具有指定的长度。 
*/
#include<bits/stdc++.h>
using namespace std;
string s;
map<string,int>f;
int find(string x){ 
    if(f[x]!=0)return f[x];
    int tmp=1;
    int l=x.size();
    for(int i=1;i*2<l;i++){ 
        if(x.substr(0,i)==x.substr(l-i,i)) 
            tmp+=find(x.substr(i,l-i))+find(x.substr(0,l-i));
        if(x.substr(0,i)==x.substr(i,i)) 
            tmp+=find(x.substr(i,l-i));
        if(x.substr(l-2*i,i)==x.substr(l-i,i)) 
            tmp+=find(x.substr(0,l-i));
    } 
    return f[x]=tmp%2014;
} 
int main(){ 
    cin>>s;
    cout<<(find(s)+2014-1)%2014;
    return 0;
} 
100分 STL+记忆化搜索
 
原文地址:https://www.cnblogs.com/thmyl/p/7588449.html