Number Sequence (HDU 1711)

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24116    Accepted Submission(s): 10232


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 
Sample Output
6
-1
 
#include<iostream>
#include<cstring>
using namespace std;
int a[1000010],b[1000010],l1,l2;
int Case,ne[1000010];
void get_ne()
{
    int j=0,k=-1;
    ne[0]=-1;
    while(j<l2)
    {
        if(k==-1||b[j]==b[k])
            ne[++j]=++k;
        else k=ne[k];
    }
}
void kmp()
{
    int i=0,j=0;
    get_ne();
    while(i<l1)
    {
        if(j==-1||a[i]==b[j])i++,j++;
        else j=ne[j];
        if(j==l2) {cout<<i-l2+1<<endl;return;}
    }
    cout<<-1<<endl;
    return;
}
int main()
{
    cin>>Case;
    while(Case--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        cin>>l1>>l2;
        for(int i=0;i<l1;i++)cin>>a[i];
        for(int j=0;j<l2;j++)cin>>b[j];
        kmp();
    }
}
原文地址:https://www.cnblogs.com/thmyl/p/6285995.html