ZOJ3712Hard to Play

Hard to Play

Time Limit: 2 Seconds      Memory Limit: 65536 KB

MightyHorse is playing a music game called osu!.

After playing for several months, MightyHorse discovered the way of calculating score in osu!:

1. While playing osu!, player need to click some circles following the rhythm. Each time a player clicks, it will have three different points: 300, 100 and 50, deciding by how clicking timing fits the music.

2. Calculating the score is quite simple. Each time player clicks and gets P points, the total score will add P, which should be calculated according to following formula:

P = Point * (Combo * 2 + 1)

Here Point is the point the player gets (300, 100 or 50) and Combo is the number of consecutive circles the player gets points previously - That means if the player doesn't miss any circle and clicks the ith circle, Combo should be i - 1.

Recently MightyHorse meets a high-end osu! player. After watching his replay, MightyHorse finds that the game is very hard to play. But he is more interested in another problem: What's the maximum and minimum total score a player can get if he only knows the number of 300, 100 and 50 points the player gets in one play?

As the high-end player plays so well, we can assume that he won't miss any circle while playing osu!; Thus he can get at least 50 point for a circle.

Input

There are multiple test cases.

The first line of input is an integer T (1 ≤ T ≤ 100), indicating the number of test cases.

For each test case, there is only one line contains three integers: A (0 ≤ A ≤ 500) - the number of 300 point he gets, B (0 ≤ B ≤ 500) - the number of 100 point he gets and C (0 ≤ C ≤ 500) - the number of 50 point he gets.

Output

For each test case, output a line contains two integers, describing the minimum and maximum total score the player can get.

Sample Input

1
2 1 1 

Sample Output

2050 3950
--------------------------------------------------------------------------------
这题题意理解了就是水题一道,大概意思就是游戏有三种分数:300,100和50,假设每次都能连击,求最低连击得分和最高连击得分。
#include<stdio.h>
int main()
{
	int t,n300,n100,n50,max,min,i,j;
	scanf("%d",&t);
	while(t--)
	{
		max=min=0;
		scanf("%d%d%d",&n300,&n100,&n50);
		for(i=0;i<n300;i++)
			min+=300*(i*2+1);
		for(j=i;j<n300+n100;j++)
			min+=100*(j*2+1);
		for(i=j;i<n300+n100+n50;i++)
			min+=50*(i*2+1);
		for(i=0;i<n50;i++)
			max+=50*(i*2+1);
		for(j=i;j<n100+n50;j++)
			max+=100*(j*2+1);
		for(i=j;i<n300+n100+n50;i++)
			max+=300*(i*2+1);
		printf("%d %d\n",min,max);
	}
	return 0;
}
原文地址:https://www.cnblogs.com/tengtao93/p/3091438.html