2^x mod n = 1

Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.
 


Input
One positive integer on each line, the value of n.
 


Output
If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.
 


Sample Input

2 5
 

 

Sample Output
2^? mod 2 = 1
2^4 mod 5 = 1


正确算法:
import java.util.*;

/**
 * 此题容易超时,所以在每次循环中都要将次方值模以n。
 */
public class 二的x次方_mod_n_等于_1 {

    public static void main(String[] args) {
        Scanner input = new Scanner(System.in);
        while (input.hasNext()) {

            int n = input.nextInt();

            if (n % 2 == 0 || n == 1) {
                System.out.println("2^? mod " + n + " = 1");
                continue;
            }

            int s = 1;
            for (int i = 1; i > 0; i++) {

                s = s * 2;
                if (s % n == 1) {

                    System.out.println("2^" + i + " mod " + n + " = 1");
                    break;
                }
                s = s % n;// 这一步可以如果不写,就会超时
            }

        }

    }

}


 
 
原文地址:https://www.cnblogs.com/syjp/p/10360530.html