[YTU]_2432 (C++习题 对象数组输入与输出)

题目描述

建立一个对象数组,内放n(n<10)个学生的数据(学号、成绩),用指针指向数组首元素,输出第奇数(1,3,5,7)个学生的数据。

输入

n和n个学生的学号、成绩

输出

奇数学生的数据

样例输入

5
101 78.5
102 85.5
103 98.5
104 100.0
105 95.5

样例输出

101 78.50
103 98.50
105 95.50
#include <iostream>
#include <iomanip>
using namespace std;
class Student
{
public:
    void input();
    void display();
    int name;
    double score;
};
void Student::input()
{
    cin>>name>>score;
}
void Student::display()
{
    cout<<name<<' '<<score<<endl;
}
int main()
{
    const int NUM=10;
    Student stud[NUM];
    int n,i;
    cin>>n;
    for(i=0; i<n; i++)
        stud[i].input();
    cout<<setiosflags(ios::fixed);
    cout<<setprecision(2);
    Student *p=stud;
    for(i=0; i<n; p+=2,i+=2)
        p->display();
    return 0;

原文地址:https://www.cnblogs.com/sxy201658506207/p/7586367.html