[YTU]_2383 ( 矩形类定义【C++】)

题目描述

定义一个矩形类,数据成员包括左下角和右上角坐标,定义的成员函数包括必要的构造函数、输入坐标的函数,以及计算并输出矩形面积的函数。要求使用提示中给出的测试函数并不得改动。

输入

四个数,分别表示矩形左下角和右上角顶点的坐标,如输入3.7 0.4 6.5 4.9,代表左下角坐标为(3.7, 0.4),右上角坐标为(6.5, 4.9)。

输出

输出一共有3行(请参考提示(hint)中的main函数):
第一行:由输入的坐标确定的矩形对象p1的面积
第二行:由对象复制得到的矩形对象p2的面积
第三行:直接初始化得到的矩形对象p3的面积

样例输入

3.7 0.4 6.5 4.9

样例输出

12.6
12.6
10
#include <iostream>
using namespace std;
class Rectangle
{
public:
    void input();
    void input(int x11,int y11,int x22,int y22);
    void output();
private:
    double x1,y1,x2,y2;
};
int main()
{
    Rectangle p1;
    p1.input();
    p1.output();
    Rectangle p2(p1);
    p2.output();
    Rectangle p3;
    p3.input(1,1,6,3);
    p3.output();
    return 0;
}
void Rectangle::input()
{
    cin>>x1>>y1>>x2>>y2;
}
void Rectangle::input(int x11,int y11,int x22,int y22)
{
    x1=x11;
    y1=y11;
    x2=x22;
    y2=y22;
}
void Rectangle::output()
{
    cout<<(x2-x1)*(y2-y1)<<endl;
}

原文地址:https://www.cnblogs.com/sxy201658506207/p/7586365.html