A-Apple Catching(POJ 2385)

Apple Catching
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8759   Accepted: 4264

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS: 

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice. 

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

Source

简单dp。
比赛的时候一直没改出来,主要是感觉样例过了,就应该是小问题,其实不然,样例毕竟坑啊。
这题其实一开始思路没错,但是没想清楚,就开始敲,敲完之后觉得时出了小问题,就一直搁那瞅,到最后也没醒悟。比完之后过了一段时间做,竟然还犯了同样的错误,我真是好记性啊(平时也没感觉粗来啊)。不过这次终于改过来了。
#include <cstdio>
#include <iostream>
#include <sstream>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <string>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <algorithm>
using namespace std;
#define ll long long
#define _cle(m, a) memset(m, a, sizeof(m))
#define repu(i, a, b) for(int i = a; i < b; i++)
#define MAXN 1005
int d[MAXN][35][2];
int tree[MAXN];
int main()
{
    int t, w;
    memset(d, 0, sizeof(d));
    scanf("%d%d", &t, &w);
    for(int i = 1; i <= t; i++) {
            scanf("%d", &tree[i]);
            tree[i]--;
    }
    for(int i = 1; i <= t; i++) {
            d[i][0][tree[i]] = d[i - 1][0][tree[i]] + 1,
            d[i][0][!tree[i]] = d[i - 1][0][!tree[i]];
       for(int j = 1; j <= w; j++)
            d[i][j][tree[i]] = max(d[i - 1][j - 1][!tree[i]], d[i - 1][j][tree[i]]) + 1,
            d[i][j][!tree[i]] = d[i - 1][j][!tree[i]];
    }
    int maxn = -1;
    for(int i = 0; i <= w; i++) maxn = max(maxn, max(d[t][i][0], d[t][i][1]));
    printf("%d", maxn);
    return 0;
}
View Code
原文地址:https://www.cnblogs.com/sunus/p/4476943.html