poj2010 Moo University

Description

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,"Moo U" for short. 

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000. 

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university's limited fund (whose total money is F, 0 <= F <= 2,000,000,000). 

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible. 

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it. 

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves. 

Input

* Line 1: Three space-separated integers N, C, and F 

* Lines 2..C+1: Two space-separated integers per line. The first is the calf's CSAT score; the second integer is the required amount of financial aid the calf needs 

Output

* Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1. 

Sample Input

3 5 70
30 25
50 21
20 20
5 18
35 30

Sample Output

35

Hint

Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70. 
 
中文题意:有c头奶牛,每头奶牛有两个属性socre,money;从中选取n头奶牛,n一定是奇数,使得这n头奶牛的money属性的和小于等于f,在满足这个条件的前提下,使得这n头奶牛的中位数(score属性的中位数)尽可能的大,并输出score的中位数,如果不能满足前提条件就输出-1;
思路:将c头奶牛按照score属性从大到小进行排序,枚举遍历,在第i头奶牛的前i-1头中找出n/2头奶牛(money属性值最小的前n/2奶牛),同理在第i头奶牛后找出n/2头奶牛,使得money和最小。第一个满足前n/2头奶牛money和加上后n/2头奶牛money和加上第i头奶牛的money<=f,输出第i头奶牛的score即可;否则输出-1;
超时代码:

#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
struct node{
int b,d;
}a[100005];
int cmp(struct node x,struct node y){
if(x.b==y.b) return x.d<y.d;
else return x.b>y.b;
}
int main(){
int n,c,f;
cin>>n>>c>>f;
for(int i=0;i<c;i++){
scanf("%d%d",&a[i].b,&a[i].d);
}
sort(a,a+c,cmp);
int plug=0;
//for(int i=0;i<c;i++)
///printf("%d %d ",a[i].b,a[i].d);
if(n==1){
for(int i=0;i<c;i++){
if(a[i].d<=f){
cout<<a[i].b<<endl;
plug=1;
break;
}
}
}
else
for(int i=n/2;i<=c-1-n/2;i++){
priority_queue<int ,vector<int>,greater<int> >q;//前面
priority_queue<int ,vector<int>,greater<int> >p;//后面
for(int j=0;j<i;j++)
q.push(a[j].d);
int cost=0;
for(int j=0;j<n/2;j++)
cost+=q.top(),q.pop();
for(int j=i+1;j<c;j++)
p.push(a[j].d);
for(int j=0;j<n/2;j++)
cost+=p.top(),p.pop();
if(cost+a[i].d<=f){
cout<<a[i].b<<endl;
plug=1;
//cout<<1<<" "<<cost<<endl;
break;
}
//cout<<1<<" "<<cost<<endl;
if(plug==0) cout<<"-1"<<endl;
}
return 0;
}

这么写,会有很多次不必要的push()操作,使得超时,其中push()操作是n^2级别的;

真正的AC代码,push()操作是n级别的:

#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
struct node{
int score,money;
}cow[100005];
int before[100005],after[100005];//分别表示前面部分的最小,和后面部分的最小,包括i本身
int cmp(struct node a,struct node b){
if(a.score==b.score) return a.money<b.money;
else return a.score>b.score;
}
int main(){
int n,c,f;
cin>>n>>c>>f;
for(int i=0;i<c;i++)
scanf("%d%d",&cow[i].score,&cow[i].money);
sort(cow,cow+c,cmp);
int sum=0;
priority_queue<int >q;
for(int i=0;i<n/2;i++) q.push(cow[i].money),sum+=cow[i].money;
before[n/2-1]=sum;
for(int i=n/2;i<=c-1-n/2;i++){
sum+=cow[i].money;
q.push(cow[i].money);
sum-=q.top();
q.pop();
before[i]=sum;
}
sum=0;
while(!q.empty()) q.pop();
for(int i=c-1;i>c-1-n/2;i--) q.push(cow[i].money),sum+=cow[i].money;
after[c-n/2]=sum;
for(int i=c-1-n/2;i>n/2;i--) {
sum+=cow[i].money;
q.push(cow[i].money);
sum-=q.top();
q.pop();
after[i]=sum;
}
int plug=0;
for(int i=n/2;i<=c-1-n/2;i++){
if(before[i-1]+after[i+1]+cow[i].money<=f){
plug=1;
cout<<cow[i].score<<endl;
break;
}
}
if(!plug) cout<<"-1"<<endl;
return 0;
}


作者:孙建钊
出处:http://www.cnblogs.com/sunjianzhao/
本文版权归作者和博客园共有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利。

原文地址:https://www.cnblogs.com/sunjianzhao/p/11600003.html