HDU 1232 畅通工程(最小生成树+并查集)

畅通工程

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 59   Accepted Submission(s) : 37

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。

Input

测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N 
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。

Output

对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。

Sample Input

3 3
1 2 1
1 3 2
2 3 4
1 3
2 3 2
0 100

Sample Output

3
?
#include <iostream>
#include <queue>
using namespace std;

int n,m,i,flag;
int sum;
int team[105];

struct node
{
    int x,y,w;
    node(int a,int b,int c){x=a;y=b;w=c;}
};
struct cmp
{
    bool operator()(node a,node b)
    {
        return a.w>b.w;
    }
};

int findteam(int k)
{
    if (team[k]!=k)
    {
        team[k]=findteam(team[k]);
        return team[k];
    } else return k;
}
int main()
{
    while (cin>>n>>m&&n)
    {

        for(int i=1;i<=m;i++) team[i]=i;
        priority_queue<node,vector<node>,cmp> path;
        for(int i=0;i<n;i++)
        {
            int x,y,w;
            cin>>x>>y>>w;
            path.push(node(x,y,w));
        }
        sum=0;
        flag=0;
        while(!path.empty())
        {
            node p=path.top();
            path.pop();
            int fx=findteam(p.x);
            int fy=findteam(p.y);
            if (fx!=fy)
            {
                team[fx]=fy;
                sum+=p.w;
            }
            int k=findteam(1);
            for(i=2;i<=m;i++)
            if (k!=findteam(team[i])) break;
            if (i>m) {flag=1; break;}
        }
        if (flag) cout<<sum<<endl;
           else cout<<"?"<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/stepping/p/5723076.html