HDU1969:Pie(二分)

Pie

Time Limit : 5000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 59   Accepted Submission(s) : 31

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655
#include <iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
using namespace std;
int t,n,f,i,num,x;
double pi=acos(-1.0);   //不能写3.1415926
double l,r,mid;
double s[10005];
int cmp(double a,double b)
{
    return a>b;
}
int main()
{
     scanf("%d",&t);
     for(;t>0;t--)
     {
         scanf("%d%d",&n,&f);
         f++;
         double maxn=0,sum=0;
         for(i=1;i<=n;i++)
         {
             scanf("%d",&x);
             s[i]=pi*x*x;
             maxn=max(maxn,s[i]);
             sum=sum+s[i];
         }
       l=maxn/f;
       r=sum/f;
       while(l+0.00001<r)
       {
           mid=(l+r)/2;
           num=0;
           for(i=1;i<=n;i++)   num+=(int)(s[i]/mid);
           if (num>=f)  l=mid;
           if (num<f)  r=mid;
       }
       printf("%.4lf\n",l);
       //printf("%lf\n",acos(-1.0));;
     }
    return 0;
}
原文地址:https://www.cnblogs.com/stepping/p/5669072.html