hdu1501 Zipper

Zipper

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 59   Accepted Submission(s) : 26

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output

For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

Source

Pacific Northwest 2004

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int t,flag,l1,l2,l3;
char ch1[205],ch2[205],ch3[420];
int f[205][205];
void dfs(int i,int j,int k)
{
    if (k==l3)
    {
        flag=1;
        return;
    }
    if (f[i][j]) return;
    f[i][j]=1;
    if (i<l1)
     if (ch3[k]==ch1[i]) dfs(i+1,j,k+1);
    if (flag) return;
    if (j<l2)
    if (ch3[k]==ch2[j]) dfs(i,j+1,k+1);
    if (flag) return;
}
int main()
{
    scanf("%d",&t);
    for(int tt=1;tt<=t;tt++)
    {
        scanf("%s%s%s",&ch1,&ch2,&ch3);
        l1=strlen(ch1);
        l2=strlen(ch2);
        l3=strlen(ch3);
        printf("Data set %d: ",tt);
        flag=0;
        memset(f,0,sizeof(f));
        dfs(0,0,0);
        if (flag) printf("yes\n");
            else printf("no\n");
    }
    return 0;
}
原文地址:https://www.cnblogs.com/stepping/p/5667529.html