HDU 1175 连连看

连连看

Time Limit : 20000/10000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 114   Accepted Submission(s) : 29

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。

Input

输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!

Output

每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。

Sample Input

3 4
1 2 3 4
0 0 0 0
4 3 2 1
4
1 1 3 4
1 1 2 4
1 1 3 3
2 1 2 4
3 4
0 1 4 3
0 2 4 1
0 0 0 0
2
1 1 2 4
1 3 2 3
0 0

Sample Output

YES
NO
NO
NO
NO
YES

Author

lwg
#include <iostream>
#include<cstdio>
#include<deque>
#include<cstring>
using namespace std;
struct node
{
    int x,y,num;
};
  deque<node> s;
int i,n,m,j,sx,sy,tx,ty,t;
int vis[1002][1002],a[1002][1002];
int dr[4][2]={ {1,0},{0,1},{0,-1},{-1,0} };

int bfs()
{
    node p;
    p.x=sx;
    p.y=sy;
    p.num=-1;
    vis[sx][sy]=1;
    s.push_back(p);
    while(!s.empty())
    {
        node t;
        t=s.front();
        for(int i=0;i<4;i++)
        {
            int xx=t.x+dr[i][0];
            int yy=t.y+dr[i][1];
            while(xx>0 && xx<=n && yy>0 && yy<=m && a[xx][yy]==0)
            {
                if (!vis[xx][yy])
                {
                    p.x=xx;
                    p.y=yy;
                    p.num=t.num+1;
                    vis[xx][yy]=1;
                    s.push_back(p);

                }
                 xx=xx+dr[i][0];
                 yy=yy+dr[i][1];
            }
            if (xx==tx && yy==ty)
                if (t.num+1>2) return 0;
                            else return 1;
        }
        s.pop_front();
    }
    return 0;
}
int main()
{
    while(~scanf("%d%d",&n,&m) && n!=0 )
    {
        for(i=1;i<=n;i++)
            for(j=1;j<=m;j++)
             scanf("%d",&a[i][j]);
        scanf("%d",&t);
        for(;t>0;t--)
        {
            scanf("%d%d%d%d",&sx,&sy,&tx,&ty);
            if (a[sx][sy]!=a[tx][ty] || a[sx][sy]==0 || a[tx][ty]==0)
            {
                printf("NO\n");
                continue;
            }
            s.clear();
            memset(vis,0,sizeof(vis));
            if(bfs()) printf("YES\n");
                else printf("NO\n");
        }
    }
    return 0;
}
原文地址:https://www.cnblogs.com/stepping/p/5648419.html