[ACM]Let the Balloon Rise

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

Author

WU, Jiazhi

Source

ZJCPC2004



解题思路:

题目要求对于每组数据,输出出现次数最多的那个颜色,贪心,利用两层循环,把每一种颜色出现的次数都统计出来,进行比较,用临时变量temp保存颜色出现次数最多的那个颜色,代码中会出现一种颜色统计两次或多次的情况,不过不影响结果,因为有比较的代码。


代码:

#include <iostream>
#include <string>
using namespace std;
string color[1003];//用来保存每次输入的颜色
int main()
{
    int n,i,j;
    while(cin>>n&&n)
    {
        for(i=1;i<=n;i++)
            cin>>color[i];
        int count=0;
        int max=0;
        string temp;
        for(i=1;i<=n;i++)//外层循环代表输入的每一个颜色
          {
           for(j=1;j<=n;j++)//内层循环对于每一个外层颜色都从头到尾统计一遍
        {
            if(color[i]==color[j])//颜色相同
                count++; //用来外层循环每一种颜色出现的次数
        }
        if(max<count)
            {
                max=count; //当前颜色出现的次数大于上一次统计的颜色最大次数
                temp=color[i];//temp为出现次数最多的那个颜色
            }
        count=0;
          }
        cout<<temp<<endl;
    }
    return 0;
}

运行截图:



原文地址:https://www.cnblogs.com/sr1993/p/3697840.html