算法分析实验之Locker doors

题目描述

There are n lockers in a hallway numbered sequentially from 1 to n. Initially, all the locker doors are closed. You make n passes by the lockers, each time starting with locker #1. On the ith pass, i = 1, 2, ..., n, you toggle the door of every ith locker: if the door is closed, you open it, if it is open, you close it. For example, after the first pass every door is open; on the second pass you only toggle the even-numbered lockers (#2, #4, ...) so that after the second pass the even doors are closed and the odd ones are opened; the third time through you close the door of locker #3 (opened from the first pass), open the door of locker #6 (closed from the second pass), and so on. After the last pass, which locker doors are open and which are closed? How many of them are open? Your task is write a program to output How many doors are open after the last pass? Assumptions all doors are closed at first.

输入

a positive numbers n, total doors. n<=100000

输出

a positive numbers ,the total of doors opened after the last pass.

样例输入复制

10

样例输出

3



题目分析:
最开始 0 0 0 0 0 0 0 0 0 0
第一次 1 1 1 1 1 1 1 1 1 1
第二次 1 0 1 0 1 0 1 0 1 0
第三次 1 0 0 0 1 1 1 0 0 0
第四次 1 0 0 1 1 1 1 1 0 0
第五次 1 0 0 1 0 1 1 1 0 1
第六次 1 0 0 1 0 0 1 1 0 1
第七次 1 0 0 1 0 0 0 1 0 1
第八次 1 0 0 1 0 0 0 0 0 1
第九次 1 0 0 1 0 0 0 0 1 1
第十次 1 0 0 1 0 0 0 0 1 0


从这个规律我们可以看出,每次关闭第i次经过的i的整数倍的门,根据最后的结果可以看出来,这就是求n内的平方数有多少个(例:n=10,平方数为1,4,9,三个)

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

 int main(){
    int n;
    int count = 0;
    cin >> n;
    for( int i = 1; i * i <= n; i++){
        count++;
    }
    cout << count << endl;
    return 0;
 }

,,

原文地址:https://www.cnblogs.com/solititude/p/12551608.html