621

 Secret Research 

At a certain laboratory results of secret research are thoroughly encrypted. A result of a single experiment is stored as an information of its completion:


`positive result',`negative result',`experiment failed' or`experiment not completed'


The encrypted result constitutes a string of digits S, which may take one of the following forms:


$ullet$
positive result 		 S = 1 or S = 4 or S = 78 
$ullet$
negative result 		 S = S35 
$ullet$
experiment failed 		 S = 9S4 
$ullet$
experiment not completed 		 S = 190S

(A sample result S35 means that if we add digits 35 from the right hand side to a digit sequence then we shall get the digit sequence corresponding to a failed experiment)


You are to write a program which decrypts given sequences of digits.

Input 

A integer n stating the number of encrypted results and thenconsecutive n lines, each containing a sequence of digits given as ASCII strings.

Output 

For each analysed sequence of digits the following lines should be sent to output (in separate lines):


		 + 		  for a positive result
		 - 		  for a negative result
		 * 		  for a failed experiment
		 ? 		  for a not completed experiment

In case the analysed string does not determine the experiment result, a first match from the above list should be outputted.

Sample Input 

4
78
7835
19078
944

Sample Output 

+
-
?
*
#include<stdio.h>
#include<string.h>
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		char a[1005]={0};
		scanf("%s",a);
		if(strlen(a)<=2)
			puts("+");
		else if(a[strlen(a)-1]=='5'&&a[strlen(a)-2]=='3')
			puts("-");
		else if(a[0]=='9'&&a[strlen(a)-1]=='4')
			puts("*");
		else if(a[0]=='1'&&a[1]=='9'&&a[2]=='0')
			puts("?");			
	}
	return 0;
}


原文地址:https://www.cnblogs.com/snake-hand/p/3151315.html