Fliptile POJ

Fliptile
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 16483   Accepted: 6017

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

题意:只含有0和1的格子,每次都可以反转其中一个,但反转的时候,这个格子的上下左右的四个格子也被反转了,就是一次反转像“十”一样的五个格子,求出最小步数完成时的每个格子的翻转次数,最小步数的解有多个时,输出字典序最小的一组。不存在的话就输出IMPOSSIBLE
思路:一个格子翻转两次会恢复原状,所以多次翻转的多余的。这道题目我们可以先翻转第一行,如果第一行翻转好了再翻转第二行,最后一行应该是不用翻转的,因为翻转势必会使得前一行已经翻转好的重新变1,所以最后要判断一下最后一行是不是都是0,如果有1的话那就意味着不存在可行的操作方法
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<set>
#include<vector>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-10
typedef long long ll;
const int maxn = 20;
const int mod = 1e9 + 7;
int gcd(int a, int b) {
    if (b == 0) return a;  return gcd(b, a % b);
}
const int dx[5]={-1,0,0,0,1};
const int dy[5]={0,-1,0,1,0};
int M,N,tile[maxn][maxn];
int opt[maxn][maxn];      //保存最优解
int flip[maxn][maxn];    //保存中间结果
//查询(x,y)的颜色
int get(int x,int y)
{
    int c=tile[x][y];
    for(int d=0;d<5;d++)
    {
        int nx=x+dx[d],ny=y+dy[d];
        if(0<=nx && nx<M && 0<=ny && ny<N)
            c+=flip[nx][ny];
    }
    return c%2;
}
  //求出第一行确定情况下的最小操作次数
  //不存在解就返回-1
int calc() {
  //求出从第二行开始的翻转方法
for(int i=1;i<M;i++) for(int j=0;j<N;j++) if(get(i-1,j)!=0) //(i-1,j)是黑色格子就必须要翻转 flip[i][j]=1;
  //判断最后一行是否是全白
for(int j=0;j<N;j++) if(get(M-1,j)!=0) return -1;
  //统计翻转的次数
int res=0; for(int i=0;i<M;i++) for(int j=0;j<N;j++) res+=flip[i][j]; return res; } void solve() { int res=-1;
//按照字典序尝试第一行的所有可能性
for(int i=0;i<(1<<N);i++) { memset(flip,0,sizeof(flip)); for(int j=0;j<N;j++) flip[0][N-j-1]=i>>j&1; int num=calc(); if(num>=0 && (res<0 || res>num)) { res=num; memcpy(opt,flip,sizeof(flip)); } } if(res<0) printf("IMPOSSIBLE "); else { for(int i=0;i<M;i++) { for(int j=0;j<N;j++) { if(j==0) printf("%d",opt[i][j]); else printf(" %d",opt[i][j]); } printf(" "); } } } int main() { cin>>M>>N; for(int i=0;i<M;i++) for(int j=0;j<N;j++) { cin>>tile[i][j]; } solve(); return 0; }
原文地址:https://www.cnblogs.com/smallhester/p/9501404.html