[结题报告]686 Goldbach's Conjecture (II) Time limit: 3.000 seconds


  Goldbach's Conjecture (II) 

Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.


This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.


A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1p2) and (p2p1) separately as two different pairs.

Input 

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 215. The end of the input is indicated by a number 0.

Output 

Each output line should contain an integer number. No other characters should appear in the output.

Sample Input 

6
10
12
0

Sample Output 

1
2
1

参考代码:
任何一个比4大的偶数一定能够找到2个质数使其和相等。例如: 8=3+5(3和5都是奇数,且是质数) 20=3+17=7+13 42=5+37=11+31=13+29=19+23 你的任务就是写一个程式输出对每一个大于4的偶数,可以找到几组这样的奇数质数的组合。我的思路是,依次求出N的因子,然后判断因子是否为质数,因为因子总是两两配对,所以我干脆就算全算,最后除2就行.请注意:我们只对有几组不同的组合有兴趣,所以(p1,p2)和(p2,p1)不应该被视为不同的组合。其中有几点要注意一下,比如9(3,3)这样的组合要注意一下。
#include"stdio.h"
#include"math.h"
int fun(int n)   //判断是否为质数 
{ int t,m;
  m=(int)sqrt(n);
  for(t=2;t<=m;t++)
   if(n%t==0)
   return 0;
  return 1;  
    }
int main(void)
{ int n,m,i,flag1,flag2,count;
  while(scanf("%d",&n)&&n)
  { count=0;
    for(i=2;i<=n-2;i++)
    {m=n-i;
     flag1=fun(i);
     flag2=fun(m);
     if(flag1&&flag2)
      {count++;
       if(i==m)     //因为输出时/2,所以当3数相等时,当2组算 
       count++;}
       }
     printf("%d\n",count/2); 
                           }return 0;
      }

原文地址:https://www.cnblogs.com/sjy123/p/2923263.html