Hdu 1124 Factorial

先上题目

Problem Description
  The most important part of a GSM network is so called Base Transceiver Station (BTS). These transceivers form the areas called cells (this term gave the name to the cellular phone) and every phone connects to the BTS with the strongest signal (in a little simplified view). Of course, BTSes need some attention and technicians need to check their function periodically.
  ACM technicians faced a very interesting problem recently. Given a set of BTSes to visit, they needed to find the shortest path to visit all of the given points and return back to the central company building. Programmers have spent several months studying this problem but with no results. They were unable to find the solution fast enough. After a long time, one of the programmers found this problem in a conference article. Unfortunately, he found that the problem is so called "Travelling Salesman Problem" and it is very hard to solve. If we have N BTSes to be visited, we can visit them in any order, giving us N! possibilities to examine. The function expressing that number is called factorial and can be computed as a product 1.2.3.4....N. The number is very high even for a relatively small N.

  The programmers understood they had no chance to solve the problem. But because they have already received the research grant from the government, they needed to continue with their studies and produce at least some results. So they started to study behaviour of the factorial function.

  For example, they defined the function Z. For any positive integer N, Z(N) is the number of zeros at the end of the decimal form of number N!. They noticed that this function never decreases. If we have two numbers N1<N2, then Z(N1) <= Z(N2). It is because we can never "lose" any trailing zero by multiplying by any positive number. We can only get new and new zeros. The function Z is very interesting, so we need a computer program that can determine its value efficiently.
 
Input
There is a single positive integer T on the first line of input. It stands for the number of numbers to follow. Then there is T lines, each containing exactly one positive integer number N, 1 <= N <= 1000000000.
 
Output
For every number N, output a single line containing the single non-negative integer Z(N).
 
Sample Input
6
3
60
100
1024
23456
8735373
 
Sample Output
0
14
24
253
5861
2183837
 
 
 
   这道题目有很多方法可以解决,在网上看到有人用dp,由于我对dp还没有多少认识,所以就···我用的是数论的方法。
   先说说题目的意思,就是求N!的结果中0的个数。因为2*5==10;所以就是求5的个数。
   如何找出5的幂次呢?我参考了一下http://blog.csdn.net/lulipeng_cpp/article/details/7606080的方法= =
       首先对于N!,每一个乘数是逐渐加一变化的,所以能被5整除的数是每5个数出现一次。那就是说一个数a/5就会得到这连续的N个数中可以被5
整除的数的个数。但是,这样就足够了吗?
   明显不行。因为a/5的商可能还可以被5整除,需要把商中5的个数也要交上去。并且直到没有5了(这里有点费解= =)
      至于数据的大小不是问题,和成曾经做的3n+1问题是相似的。
 
上代码:
 
#include <stdio.h>
#include <string.h>
using namespace std;

int main()
{
    int n,k,t;
    //freopen("data.txt","r",stdin);
    scanf("%d",&t);
    while(t--)
    {
        k=0;
        scanf("%d",&n);
        while(n)
        {
            n/=5;
            k+=n;
        }
        printf("%d\n",k);
    }
    return 0;
}


/*
6
3
60
100
1024
23456
8735373

0
14
24
253
5861
2183837


*/
  
原文地址:https://www.cnblogs.com/sineatos/p/3060059.html