题目1014:排名

//成绩降序排列,成绩相等时学号升序排列

bool cmp1(struct score a,struct score b)
{
if(a.totalScore==b.totalScore)
return a.str<b.str;
else
return a.totalScore>b.totalScore;
}
//比较函数
sort(stuInfo,stuInfo+stNum,cmp1);
题目描述:
    今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的考生,并将他们的成绩按降序打印。
输入:

    测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N < 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号(题目号由1到M)。 
    当读入的考生人数为0时,输入结束,该场考试不予处理。

输出:

    对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考号的升序输出。

样例输入:
4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
1 2 40
10 30
CS001 1 2
2 3 20
10 10 10
CS000000000000000001 0
CS000000000000000002 2 1 2
0
样例输出:
3
CS003 60
CS001 37
CS004 37
0
1
CS000000000000000002 20

#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
bool cmp1(struct score a,struct score b);
struct score
{
	string str;
	int count;
	int totalScore;

}score;
int main()
{
	int stNum,exNum,averScore;
	while(cin>>stNum&&stNum!=0)
	{
		cin>>exNum>>averScore;
		int stCount=0;
		struct score stuInfo[1050];
		int sc[13];
		for(int i=1;i<=exNum;i++)
		{
			cin>>sc[i];
		}
		int count=0;
		int score;
		int totalScore=0;
		for(int j=0;j<stNum;j++)
		{
			totalScore=0;
			cin>>stuInfo[j].str;
			cin>>count;
			stuInfo[j].count=count;
			if(!count)stuInfo[j].totalScore=0;
			for(int i=0;i<count;i++)
			{
				cin>>score;
				totalScore+=sc[score];
			}
			stuInfo[j].totalScore=totalScore;
			if(totalScore>=averScore)stCount++;
		}
		sort(stuInfo,stuInfo+stNum,cmp1);
		cout<<stCount<<endl;
		for(int j=0;j<stNum;j++)
		{
			if(stuInfo[j].totalScore>=averScore)
				cout<<stuInfo[j].str<<' '<<stuInfo[j].totalScore<<endl;
		}
	}
	return 0;
}
bool cmp1(struct score a,struct score b)
{
	if(a.totalScore==b.totalScore)
		return a.str<b.str;
	else
		return a.totalScore>b.totalScore;
}



极简,专注,速度,极致
原文地址:https://www.cnblogs.com/simplelifestyle/p/3761888.html