树1 树的同构

题目:https://pintia.cn/problem-sets/1268384564738605056/problems/1274008636207132672

给定两棵树T1和T2。如果T1可以通过若干次左右孩子互换就变成T2,则我们称两棵树是“同构”的。例如图1给出的两棵树就是同构的,因为我们把其中一棵树的结点A、B、G的左右孩子互换后,就得到另外一棵树。而图2就不是同构的。


图1

图2

现给定两棵树,请你判断它们是否是同构的。

输入格式:

输入给出2棵二叉树树的信息。对于每棵树,首先在一行中给出一个非负整数N (10),即该树的结点数(此时假设结点从0到N1编号);随后N行,第i行对应编号第i个结点,给出该结点中存储的1个英文大写字母、其左孩子结点的编号、右孩子结点的编号。如果孩子结点为空,则在相应位置上给出“-”。给出的数据间用一个空格分隔。注意:题目保证每个结点中存储的字母是不同的。

输出格式:

如果两棵树是同构的,输出“Yes”,否则输出“No”。

输入样例1(对应图1):

8
A 1 2
B 3 4
C 5 -
D - -
E 6 -
G 7 -
F - -
H - -
8
G - 4
B 7 6
F - -
A 5 1
H - -
C 0 -
D - -
E 2 -
 

输出样例1:

Yes
 

输入样例2(对应图2):

8
B 5 7
F - -
A 0 3
C 6 -
H - -
D - -
G 4 -
E 1 -
8
D 6 -
B 5 -
E - -
H - -
C 0 2
G - 3
F - -
A 1 4
 

输出样例2:

No


题解: https://www.cnblogs.com/zhien-aa/p/6651993.html
代码:

/*
    Name: hello world.cpp
    Author: AA
    Description: 唯代码与你不可辜负
*/
#include<bits/stdc++.h>
using namespace std;
#define LL long long
#define maxn 20100
typedef struct Node {
    char data;
    int left;
    int right;
} Tree;
Tree t1[maxn], t2[maxn];
int build(Tree  T[]) {
    int n, cherk[maxn], root = -1;
    char cl, cr;
    scanf("%d", &n);
    getchar();
    if(n) {
        for(int i = 0; i < n; i++)
            cherk[i] = 0;
        for(int i = 0; i < n; i++) {
            scanf("%c %c %c", &T[i].data, &cl, &cr);
            getchar();
            if(cl != '-') {
                T[i].left = cl - '0';
                cherk[T[i].left] = 1;
            } else
                T[i].left = -1;
            if(cr != '-') {
                T[i].right = cr - '0';
                cherk[T[i].right] = 1;
            } else
                T[i].right = -1;
        }
        for(int i = 0; i < n; i++) {
            if(cherk[i] == 0) {
                root = i;
                break;
            }
        }
    }
    return root;
}
bool Isomorphic(int root1, int root2) {
    if(root1 == -1 && root2 == -1) return true;//都是空的,符合
    else if((root1 == -1 && root2 != -1) || (root1 != -1 && root2 == -1)) return false; //一个空一个不空当然不符合
    else if(t1[root1].data != t2[root2].data) return false; //元素不相等不符合
    else if(t1[root1].left == -1 && t2[root2].left == -1) //左子树都是空的话,就判断右子树
        return Isomorphic(t1[root1].right, t2[root2].right);
    else if(t1[t1[root1].left].data == t2[t2[root2].left].data)//左子树的元素都相同的话就把他们的左右子树都判断
        return (Isomorphic(t1[root1].left, t2[root2].left) && Isomorphic(t1[root1].right, t2[root2].right));
    else //最后是把左右子树交换来判断
        return (Isomorphic(t1[root1].left, t2[root2].right) && Isomorphic(t1[root1].right, t2[root2].left));
}
int main() {
    int root1, root2;
    root1 = build(t1);
    root2 = build(t2);
    if(Isomorphic(root1, root2))
        puts("Yes");
    else
        puts("No");
}
原文地址:https://www.cnblogs.com/simon-chou/p/13619892.html