A.Snake Filled

“What a boring world!”
Julyed felt so bored that she began to write numbers on the coordinate paper. She wrote a “0” on the center, then wrote the follow numbers clockwise, which looked like a snake as below.
 
“Damn! I have fulfilled the paper!”
Julyed was looking at paper. Suddenly, she began to feel curious.
“What is the nth number on the positive axis of Y axis?”
She asked tomriddly for the question. But tomriddly was so busy that he ignored Julyed. So now you have to solve this problem.

输入

Multiple test cases.
The first line contains an integer T (T <= 50), indicating the number of test cases.
Then T lines follows, one line per case. Each line contains a positive integer n (n <= 3000).

输出

One line per case. An integer indicates the nth number on the positive axis of Y axis.

样例输入

3
1
2
18

样例输出

5
18
1314


CODE:

#include <stdio.h>

int xun(int n)

{

      int i;

      if(n==0)

           i=0;

      else i=xun(n-1)+5+8*(n-1);

      return i;

}

int main()

{

      int n,i,T,num;

      while(scanf("%d",&T)!=EOF)

      {

           for(i=0;i<T;i++)

           {

                 scanf("%d",&n);

                 num=xun(n);

                 printf("%d ",num);

           }

      }

      return 0;

}
 
原文地址:https://www.cnblogs.com/shu233/p/5575560.html