第五周作业

一、

二。本题要求编写程序,输入若干英文单词,对这些单词按长度从小到大排序后输出。如果长度相同,按照输入的顺序不变。
输入格式:
输入为若干英文单词,每行一个,以#作为输入结束标志。其中英文单词总数不超过20个,英文单词为长度小于10的仅由小写英文字母组成的字符串。
输出格式:
输出为排序后的结果,每个单词后面都额外输出一个空格。
输入样例:
blue
red
yellow
green
purple

输出样例:
red blue green yellow purple

```#include <stdio.h>
#include <string.h>
main(){  
char str[20][10],t[20],str1[10]; 
int i,j,n=0;  
while(1)	{   
scanf("%s",str1);  
if(str1[0]=='#')	  
{    	
 break;    
 }   
 else	
{     
  strcpy(str[n],str1);  
  n++;      
  } 
  }    
  for(i=0;i<n-1;i++)    
  for(j=0;j<n-i-1;j++)	  
  {         
    if(strlen(str[j])>strlen(str[j+1]))		
    {         
      strcpy(t,str[j]);       
    strcpy(str[j],str[j+1]);      
    strcpy(str[j+1],t);          
    }       
    }  
    for(i=0;i<n;i++)
    {     
      printf("%s ",str[i]);   
      }

   }```

三、运行结果图

四、流程图

五、遇到的问题
1.while语句变得生疏
解决方法:复习书上以前while语句知识
2、strcpy语句运用不熟有待进一步巩固

第四周预习题
本题目要求编写程序统计一行字符中单词的个数。所谓“单词”是指连续不含空格的字符串,各单词之间用空格分隔,空格数可以是多个。
输入格式:
输入给出一行字符。
输出格式:
在一行中输出单词个数。
输入样例:
Let's go to room 209.
输出样例:
5

int main()
{
	char a;
	int cnt=0,countword=0;
 
  	while(1){
  		scanf("%c",&a);
		if(a=='
'){    
			break;
		}else if(a!=' '){ 
			if(a>='a'&&a<='z'||a>='A'&&a<='Z'||a>='0'&&a<='9')	{
				countword++;   
				cnt++;  
			}
				while(1){
					scanf("%c",&a);
					if(a==' '||a=='
'){ 
						break;
					}
					cnt++;
				}
			if(cnt>1){
				if(a>='a'&&a<='z'||a>='A'&&a<='Z'||a>='0'&&a<='9')	countword++; 
			}
			if(a=='
'){
				break; 
			}
		} 
	}
 
  	printf("%d",countword);
    return 0;
}```

运行截图
![](https://img2018.cnblogs.com/blog/1581356/201903/1581356-20190329202659254-1560997612.png)

流程图
![](https://img2018.cnblogs.com/blog/1581356/201903/1581356-20190329202757753-1813974274.png)
原文地址:https://www.cnblogs.com/shsy/p/10623687.html