1242 布局

1242 布局

 

2005年USACO

 时间限制: 1 s
 空间限制: 128000 KB
 题目等级 : 黄金 Gold
 
 
题目描述 Description

当排队等候喂食时,奶牛喜欢和它们的朋友站得靠近些。FJ有N(2<=N<=1000)头奶牛,编号从1到N,沿一条直线站着等候喂食。奶牛排在队伍中的顺序和它们的编号是相同的。因为奶牛相当苗条,所以可能有两头或者更多奶牛站在同一位置上。即使说,如果我们想象奶牛是站在一条数轴上的话,允许有两头或更多奶牛拥有相同的横坐标。

一些奶牛相互间存有好感,它们希望两者之间的距离不超过一个给定的数L。另一方面,一些奶牛相互间非常反感,它们希望两者间的距离不小于一个给定的数D。给出ML条关于两头奶牛间有好感的描述,再给出MD条关于两头奶牛间存有反感的描述。(1<=ML,MD<=10000,1<=L,D<=1000000)

你的工作是:如果不存在满足要求的方案,输出-1;如果1号奶牛和N号

奶牛间的距离可以任意大,输出-2;否则,计算出在满足所有要求的情况下,1号奶牛和N号奶牛间可能的最大距离。

输入描述 Input Description
Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
输出描述 Output Description
Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
样例输入 Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

样例输出 Sample Output

27

数据范围及提示 Data Size & Hint
 

分类标签 Tags 点此展开 

 
 
题解:
ml的正向建边,存正的权值
md的反向建边,存负的权值
正向跑一遍spfa最短路,判断一下dis[n],输出
AC代码:
#include<cstdio>
#include<queue>
using namespace std;
const int N=5e5+10;
struct node{
    int v,w,next;
}e[N<<2];
int n,ml,md,tot,head[N],in[N],dis[N];
bool vis[N];
void add(int x,int y,int z){
    e[++tot].v=y;
    e[tot].w=z;
    e[tot].next=head[x];
    head[x]=tot;
}
inline int spfa(){
    for(int i=1;i<=n;i++) dis[i]=0x3f3f3f3f;
    dis[1]=0;
    vis[1]=1;
    in[1]=1;
    queue<int>q;
    q.push(1);
    while(!q.empty()){
        int h=q.front();q.pop();
        vis[h]=0;
        for(int i=head[h];i;i=e[i].next){
            int v=e[i].v,w=e[i].w;
            if(dis[v]>dis[h]+w){
                dis[v]=dis[h]+w;
                if(!vis[v]){
                    vis[v]=1;
                    if(++in[v]==n) return -1;
                    q.push(v);
                }
            }
        }
    }
    if(dis[n]==0x3f3f3f3f) return -2;
    return dis[n];
}
int main(){
    scanf("%d%d%d",&n,&ml,&md);
    for(int i=1,x,y,z;i<=ml;i++) scanf("%d%d%d",&x,&y,&z),add(x,y,z);
    for(int i=1,x,y,z;i<=md;i++) scanf("%d%d%d",&x,&y,&z),add(y,x,-z);
    printf("%d",spfa());
    return 0;
}
原文地址:https://www.cnblogs.com/shenben/p/5880868.html