poj2011

Shortest Prefixes
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 17608   Accepted: 7658

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

Source

 题意:

 找出能唯一标示一个字符串的最短前缀,如果找不出,就输出该字符串

 题解:

在裸字典树的基础上,trie[now].w表示now这个节点被用过几次,当我们扫一个单词时,
如果它的某一个字母只用过一次,即只有它用过,那么这以前就是它的前缀。

AC代码:

#include<cstdio>
#include<cstring>
using namespace std;
const int N=1005;
const int M=27;
struct node{
    int next[M];
    int w;
}tire[N*M];
char s[N][M];
int cnt,n;
void build(int num){
    int now=0,len=strlen(s[num]);
    for(int i=0;i<len;i++){
        int x=s[num][i]-'a'+1;
        if(!tire[now].next[x])
            tire[now].next[x]=++cnt;
        now=tire[now].next[x];
        tire[now].w++;        
    }
}
void query(int num){
    int now=0,len=strlen(s[num]);
    for(int i=0;i<len;i++){
        int x=s[num][i]-'a'+1;
        now=tire[now].next[x];
        printf("%c",s[num][i]);
        if(tire[now].w==1) break;        
    }
}
int main(){
    while(scanf("%s",s[++n])==1) build(n);n--;
    for(int i=1;i<=n;i++) printf("%s ",s[i]),query(i),putchar('
');
    return 0;
}
原文地址:https://www.cnblogs.com/shenben/p/5862831.html