BZOJ 2456

 

Description

给你一个n个数的数列,其中某个数出现了超过n div 2次即众数,请你找出那个数。

Input

第1行一个正整数n。
第2行n个正整数用空格隔开。

Output

    一行一个正整数表示那个众数。

Sample Input

5
3 2 3 1 3

Sample Output

3

HINT

100%的数据,n<=500000,数列中每个数<=maxlongint。



zju2132 The Most Frequent Number

Source

 
AC代码:
#include<cstdio>
using namespace std;
int n,t,cnt;
int main(){
    scanf("%d",&n);
    for(int i=1,x;i<=n;i++){
        scanf("%d",&x);
        if(x==t) cnt++;
        else{
            cnt--;
            if(cnt<=0) cnt=1,t=x;
        }
    }
    printf("%d",t);
    return 0;
}
原文地址:https://www.cnblogs.com/shenben/p/5677208.html