Uva1055 Hashmat the Brave Warrior:

he just calculates one thing, the difference between his soldier number and the opponent's soldier number. From this difference he decides whether to fight or not. Hashmat's soldier number is never greater than his opponent.

Input

The input contains two integer numbers in every line. These two numbers in each line denotes the number of soldiers in Hashmat's army and his opponent's army or vice versa. The input numbers are not greater than 2^32. Input is terminated by End of File.

Output

For each line of input, print the difference of number of soldiers between Hashmat's army and his opponent's army. Each output should be in seperate line.

Sample Input:

10 12
10 14
100 200

Sample Output:

2
4
100

本题也是,刚开始还以为题目上说的啊一定小于b,就不用判断呢……

#include<iostream>
using namespace std;

int main()
{
    long long a, b;
    while(cin >> a >> b)
    {
        if(a > b)
        {
            long long t;
            t = a;
            a = b;
            b = t;
        }
        cout << b - a << endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/sanghai/p/2772370.html