hdu4726贪心

Kia's Calculation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 605    Accepted Submission(s): 170

Problem Description
Doctor Ghee is teaching Kia how to calculate the sum of two integers. But Kia is so careless and alway forget to carry a number when the sum of two digits exceeds 9. For example, when she calculates 4567+5789, she will get 9246, and for 1234+9876, she will get 0. Ghee is angry about this, and makes a hard problem for her to solve:
Now Kia has two integers A and B, she can shuffle the digits in each number as she like, but leading zeros are not allowed. That is to say, for A = 11024, she can rearrange the number as 10124, or 41102, or many other, but 02411 is not allowed.
After she shuffles A and B, she will add them together, in her own way. And what will be the maximum possible sum of A "+" B ?
 
Input
The rst line has a number T (T <= 25) , indicating the number of test cases.
For each test case there are two lines. First line has the number A, and the second line has the number B.
Both A and B will have same number of digits, which is no larger than 10 6, and without leading zeros.
 
Output
For test case X, output "Case #X: " first, then output the maximum possible sum without leading zeros.
 
Sample Input
1 5958 3036
 
Sample Output
Case #1: 8984
 
Source
分析:A+B后的数每位最大值为9,所以可以从第一位开始从9~0枚举,9=0+9,1+8,2+7...,注意首位不能为0即可
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=1000000+10;
char a[MAX],b[MAX];
int numa[10],numb[10];

int main(){
    int t,i,j,k,num=0;
    scanf("%d",&t);
    while(t--){
        scanf("%s%s",a,b);
        int lena=strlen(a),lenb=strlen(b);
        memset(numa,0,sizeof numa);
        memset(numb,0,sizeof numb);
        for(i=0;i<lena;++i)++numa[a[i]-'0'];
        for(i=0;i<lenb;++i)++numb[b[i]-'0'];
        printf("Case #%d: ",++num);
        for(i=9;i>=0;--i){//判断首位最大值
            for(j=1;j<10;++j){
                if((i-j+10)%10 == 0)continue;
                if(numa[j] && numb[(i-j+10)%10]){--numa[j],--numb[(i-j+10)%10];break;}
            }
            if(j != 10){printf("%d",i);break;}
        }
        if(i == 0){cout<<endl;continue;}
        if(i == -1){cout<<0<<endl;continue;}
        for(k=1;k<lena;++k){//a,b长度相等才能这样算
            for(i=9;i>=0;--i){
                for(j=0;j<10;++j){
                    if(numa[j] && numb[(i-j+10)%10]){--numa[j],--numb[(i-j+10)%10];break;}
                }
                if(j != 10){printf("%d",i);break;}
            }
        }
        cout<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/riskyer/p/3318029.html