HDU 5810 Balls and Boxes 数学

Balls and Boxes

题目连接:

http://acm.hdu.edu.cn/showproblem.php?pid=5810

Description

Mr. Chopsticks is interested in random phenomena, and he conducts an experiment to study randomness. In the experiment, he throws n balls into m boxes in such a manner that each ball has equal probability of going to each boxes. After the experiment, he calculated the statistical variance V as
V=∑mi=1(Xi−X¯)2m

where Xi is the number of balls in the ith box, and X¯ is the average number of balls in a box.
Your task is to find out the expected value of V.

Input

The input contains multiple test cases. Each case contains two integers n and m (1 <= n, m <= 1000 000 000) in a line.
The input is terminated by n = m = 0.

Output

For each case, output the result as A/B in a line, where A/B should be an irreducible fraction. Let B=1 if the result is an integer.

Sample Input

2 1
2 2
0 0

Sample Output

0/1
1/2

Hint

题意

有n个球,m个盒子,问你n个球放在盒子里面的方差的期望是多少。

题解:

正解是数学,但是我们是打表找规律……

答案 n(m-1)/m^2

代码

#include<bits/stdc++.h>
using namespace std;

int main(){
    long long n,m;
    while(cin>>n>>m){
        if(n==0&&m==0)break;
        long long a=n*(m-1),b=m*m;
        long long tmp = __gcd(a,b);
        cout<<a/tmp<<"/"<<b/tmp<<endl;
    }
}
原文地址:https://www.cnblogs.com/qscqesze/p/5754271.html