HDU 1969 Pie

Pie

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1105    Accepted Submission(s): 365


Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 
Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
 
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
 
Sample Output
25.1327
3.1416
50.2655
 
 
一开始看不懂题意。。
大意是:分馅饼,注意,每人(包括自己)有且只有一块,即每人的饼不能是由几块组合而成。。。。。求最大的体积,因为高是1,其实就是求做大的面积。。。
 
设最大的面积为x(即每人拿到的)。。。。转化成方程:a[1]/x + a[2]/x + ..... + a[n]/x =  y + 1
其中a[i]/x指各块馅饼最多能分给几个人。。。。由于n是变化的。。。。。所以不能直接像方程那样做。。。。。
而写出一个函数。。。。。。。。。。。注意代码中的函数中的if (count >= y + 1),为什么不是count  == y + 1呢?
因为不一定能等于y+1(除非特例),而我们求的解也只是近似解而已。。。。。。。而我们希望他接近y + 1,所以后面成立的时候
l = mid 。。。。。。即x升,y+1降。。。。。。
 
 
还有一点就是EPS不能太小。。。。不然超时。。。。。他保留4位,我们就计算到6(4+2)位就可以了。。。。
别忘了计算面积。。。。
 
 
 
View Code
#include <set>
#include <map>
#include <list>
#include <cmath>
#include <ctime>
#include <deque>
#include <queue>
#include <stack>
#include <cstdio>
#include <string>
#include <vector>
#include <cctype>
#include <cstring>
#include <sstream>
#include <fstream>
#include <cstdlib>
#include <cassert>
#include <iostream>
#include <algorithm>

using namespace std;
//Constant Declaration
/*
--------------------------*/
//#define LL long long
#define LL __int64
const int M=10010;
const int INF=1<<30;
const double EPS = 1e-6;//注意。。。。。太小超时。。。
const double PI = acos(-1.0);
/*--------------------------*/
// some essential funtion
/*
----------------------------------*/
void Swap(int &a,int &b){ int t=a;a=b;b=t; }
int Max(int a,int b){ return a>b?a:b; }
int Min(int a,int b){ return a<b?a:b; }
int Gcd(int a,int b){ while(b){b ^= a ^=b ^= a %= b;} return a; }
/*----------------------------------*/
//for (i = 0; i < n; i++)
/*
----------------------------------*/

int n;
double a[M];
int y;

bool F(double x)
{
int count = 0;
for (int i = 1; i <= n; i++)
{
count += int(a[i]*a[i]*PI / x);
}
if (count >= y + 1)
{
return 1;
}
else
{
return 0;
}
}

int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
int t, case1 = 0;
scanf("%d", &t);
int m;
int i, j;
//scanf("%d%d", &n, &m);

while (t--)
{
scanf("%d%d", &n, &y);
double sum = 0;
for (i = 1; i <= n; i++)
{
scanf("%lf", a+i);
sum += a[i]*a[i]*PI;
}

double l = 0, r = sum / (y+1);
double mid;

while (r - l > EPS)
{
mid = (l + r) / 2;

if (F(mid))
{
l = mid;
}
else
{
r = mid;
}


}
printf("%.4lf\n", mid);

}

return 0;
}
 
 
原文地址:https://www.cnblogs.com/qiufeihai/p/2408530.html