UVA548(二叉树遍历)

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a
path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values
of nodes along that path.
Input
The input file will contain a description of the binary tree given as the inorder and postorder traversal
sequences of that tree. Your program will read two line (until end of file) from the input file. The first
line will contain the sequence of values associated with an inorder traversal of the tree and the second
line will contain the sequence of values associated with a postorder traversal of the tree. All values
will be different, greater than zero and less than 10000. You may assume that no binary tree will have
more than 10000 nodes or less than 1 node.
Output
For each tree description you should output the value of the leaf node of a path of least value. In the
case of multiple paths of least value you should pick the one with the least value on the terminal node.

Sample Input
3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255

Sample Output
1
3
255

题意:定义一条路径的值为从根节点到叶子结点所有结点值的和。求值最小的那条路径的叶子结点。若两条路径的的值相同,那么求叶子结点的值较小的那个。

#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
const int MAXN=100005;
const int INF=0x3f3f3f3f;
char s[MAXN];
int mx,k;
void handle(int buf[],int &len)
{
    int l=strlen(s);
    int x=0;
    for(int i=0;i<l;i++)
    {
        if(s[i]==' ')
        {
            buf[len++]=x;
            x=0;
        }
        else
        {
            x*=10;
            x+=(s[i]-'0');
        }
    }
    buf[len++]=x;
}
int in[MAXN],len1;
int post[MAXN],len2;
void build(int l1,int r1,int l2,int r2,int sum)
{
    if(l1>r1)
    {
        return ;
    }
    if(l1==r1&&l2==r2)//走到叶子结点 
    {
        int x=sum+in[l1];
        if(x<mx)
        {
            mx=x;
            k=in[l1];
        }
        else if(x==mx)
        {
            k=min(k,in[l1]);
        }
    }
    
    int root=post[r2];
    int p=0;
    while(in[p]!=root)    p++;
    int cnt=p-l1;
    build(l1,p-1,l2,l2+cnt-1,sum+root);
    build(p+1,r1,l2+cnt,r2-1,sum+root);
}
int main()
{
    while(cin.getline(s,MAXN))
    {
        len1=len2=0;
        handle(in,len1);
        cin.getline(s,MAXN);
        handle(post,len2);
        mx=INF;    
        k=INF;
        build(0,len1-1,0,len2-1,0);
        cout<<k<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/program-ccc/p/5688780.html