CodeForces--626C--Block Towers (二分)

Time Limit: 2000MS   Memory Limit: 262144KB   64bit IO Format: %I64d & %I64u

Status

Description

Students in a class are making towers of blocks. Each student makes a (non-zero) tower by stacking pieces lengthwise on top of each other. n of the students use pieces made of two blocks and m of the students use pieces made of three blocks.

The students don’t want to use too many blocks, but they also want to be unique, so no two students’ towers may contain the same number of blocks. Find the minimum height necessary for the tallest of the students' towers.

Input

The first line of the input contains two space-separated integers n and m (0 ≤ n, m ≤ 1 000 000, n + m > 0) — the number of students using two-block pieces and the number of students using three-block pieces, respectively.

Output

Print a single integer, denoting the minimum possible height of the tallest tower.

Sample Input

Input
1 3
Output
9
Input
3 2
Output
8
Input
5 0
Output
10

Sample Output

Hint

In the first case, the student using two-block pieces can make a tower of height 4, and the students using three-block pieces can make towers of height 3, 6, and 9 blocks. The tallest tower has a height of 9 blocks.

In the second case, the students can make towers of heights 2, 4, and 8 with two-block pieces and towers of heights 3 and 6 with three-block pieces, for a maximum height of 8 blocks.

n个人使用2米长的材料,m个人使用3米长的材料,材料数量不限,每个人都建自己的塔,但是塔的高度不能有一样的,问最大高度的最小值

因为是2米跟3米的材料,所以公倍数含6的会有重复,这个是重点

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int n,m;
int judge(int x)
{
	if(x/2<n||x/3<m||x/2+x/3-x/6<m+n)
	return 0;
	return 1;
}
int main()
{
	cin>>n>>m;
	int l=0,r=10000000,mid;
	while(l<r)
	{
		mid=(l+r)/2;
		if(judge(mid))
			r=mid;
		else
			l=mid+1;
	}
	cout<<r<<endl;
	return 0;
}


原文地址:https://www.cnblogs.com/playboy307/p/5273447.html