hdoj--5630--Rikka with Chess(规律题)



Rikka with Chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 499    Accepted Submission(s): 416


Problem Description
Yuta gives Rikka a chess board of size n×m.

As we all know, on a chess board, every cell is either black or white and every two cells that share a side have different colors.

Rikka can choose any rectangle formed by board squares and perform an inversion, every white cell becomes black, and vice versa.

Rikka wants to turn all cells into the same color, please tell Rikka the minimal number of inversions she need to achieve her goal.
 

Input
The first line contains a number T(T10) ——The number of the testcases.

Each testcase contains two numbers n,m(n109,m109).
 

Output
For each testcase, print a single number which represents the answer.
 

Sample Input
3 1 2 2 2 3 3
 

Sample Output
1 2 2
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:  5639 5638 5637 5636 5635 


#include<cstdio>
#include<queue>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int a,b;
		cin>>a>>b;
		cout<<a/2+b/2<<endl;
	}
	return 0;
}



原文地址:https://www.cnblogs.com/playboy307/p/5273429.html