Codeforces--598A--Tricky Sum(数学)



Tricky Sum

Tricky SumCrawling in process... Crawling failed Time Limit:1000MS     Memory Limit:262144KB     64bit IO Format:%I64d & %I64u

Description

In this problem you are to calculate the sum of all integers from 1 to n, but you should take all powers of two with minus in the sum.

For example, for n = 4 the sum is equal to  - 1 - 2 + 3 - 4 =  - 4, because 1, 2 and 4 are 20, 21 and 22 respectively.

Calculate the answer for t values of n.

Input

The first line of the input contains a single integer t (1 ≤ t ≤ 100) — the number of values of n to be processed.

Each of next t lines contains a single integer n (1 ≤ n ≤ 109).

Output

Print the requested sum for each of t integers n given in the input.

Sample Input

Input
2
4
1000000000
Output
-4
499999998352516354

Sample Output

Hint

The answer for the first sample is explained in the statement.


1--n全部加起来,如果是2的次幂  数字就为负的,求最后的和,先利用等差序列公式(n+1)*n/2,然后扣除2的次幂

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		__int64 n;
		cin>>n;
		__int64 ans=(n+1)*n/2-2;
		for(int i=1;pow(2,i)<=n;i++)
		ans-=pow(2,i+1);
		cout<<ans<<endl;
	}
	return 0;
}

原文地址:https://www.cnblogs.com/playboy307/p/5273396.html