BZOJ 3856: Monster【杂题】

Description

Teacher Mai has a kingdom. A monster has invaded this kingdom, and Teacher Mai wants to kill it.

Monster initially has h HP. And it will die if HP is less than 1.

Teacher Mai and monster take turns to do their action. In one round, Teacher Mai can attack the monster so that the HP of the monster will be reduced by a. At the end of this round, the HP of monster will be increased by b.

After k consecutive round's attack, Teacher Mai must take a rest in this round. However, he can also choose to take a rest in any round.

Output "YES" if Teacher Mai can kill this monster, else output "NO".

Input

There are multiple test cases, terminated by a line "0 0 0 0".

For each test case, the first line contains four integers h,a,b,k(1<=h,a,b,k <=10^9).

Output

For each case, output "Case #k: " first, where k is the case number counting from 1. Then output "YES" if Teacher Mai can kill this monster, else output "NO".

Sample Input

5 3 2 2
0 0 0 0

Sample Output

Case #1: NO

题目大意:每论麦老师都要打怪物一拳,使怪物HP减少a滴血,怪物回复b滴血,麦老师每k论要休息一次,问能否打死怪物?

思路:大水题,唯一要注意的就是一击必杀的情况以及long long

#include<cstdio>
#define maxn 100009
using namespace std;
int main()
{
    long long h,a,b,k;
    int cas=0;
    while(1)
    {
        scanf("%lld%lld%lld%lld",&h,&a,&b,&k);
        if(!(h|a|b|k))break;
        printf("Case #%d: ",++cas);
        if((long long)(a-b)*k+b<0){printf("YES ");continue;}
        if((long long)h-(a-b)*k<=0){printf("YES ");continue;}
        if(a>=h){printf("YES ");continue;}
        printf("NO ");
    }
    return 0;
}

原文地址:https://www.cnblogs.com/philippica/p/4209252.html