ACDream:1210:Chinese Girls' Amusement【水题】

Chinese Girls' Amusement

Time Limit: 2000/1000MS (Java/Others)Memory Limit: 128000/64000KB (Java/Others)

SubmitStatisticNext Problem

Problem Description

      You must have heard that the Chinese culture is quite different from that of Europe or Russia. So some Chinese habits seem quite unusual or even weird to us.
      So it is known that there is one popular game of Chinese girls. N girls stand forming a circle and throw a ball to each other. First girl holding a ball throws it to the K-th girl on her left (1 ≤ K ≤ N/2). That girl catches the ball and in turn throws it to the K-th girl on her left, and so on. So the ball is passed from one girl to another until it comes back to the first girl. If for example N = 7 and K = 3, the girls receive the ball in the following order: 1, 4, 7, 3, 6, 2, 5, 1.
 To make the game even more interesting the girls want to choose K as large as possible, but they want one condition to hold: each girl must own the ball during the game.

Input

Input contains one integer number N (3 ≤ N ≤ 102000) — the number of Chinese girls taking part in the game.

Output

Output the only number — K that they should choose.

Sample Input

7
6

Sample Output

3
1

题目大意:一个n个女士的环传球,每次向左穿k个人(1<=k<=n>>1),要求每个人都穿到球,问k最大为多少

思路:这题显然要求max(k)|(1<=k<=n>>1),(k,n)=1

当n为奇数时 显然(n-1)/2为所求,当n为偶数时当n/2为偶数时减一就行 当n/2为奇数时减2就行,然后就是ACDREAM逗比的输入,while(scanf(xxx)!=EOF)竟然报WA!

#include <stdio.h>

#include <string.h>

#define maxn 2000

char ch[maxn];

void dec(char *ch,int &l)

{

    ch[1]--;

    for(int i=1;i<=l;i++)if(ch[i]<0)ch[i]+=10,ch[i+1]--;

    if(ch[l]==0)l--;

}

int main()

{

    scanf("%s",ch+1);

    int l=strlen(ch+1),flag=0;

    for(int i=1;i<=(l>>1);i++){

        int temp=ch[i];ch[i]=ch[l-i+1];ch[l-i+1]=temp;

    }

    for(int i=1;i<=l;i++)ch[i]-='0';

    if((ch[1])&1)dec(ch,l);else flag=1;

    for(int i=l;i>=1;i--)if(!ch[i]%2)ch[i]>>=1;else

    {

        ch[i-1]+=(ch[i]%2)*10;

        ch[i]=ch[i]/2;

    }

    if(ch[l]==0)l--;

    if(flag && !(ch[1]&1))dec(ch,l);else

    if(flag && (ch[1]&1))for(int i=1;i<=2;i++)dec(ch,l);

    for(int i=l;i>=1;i--)printf("%d",ch[i]);

    printf(" ");

    return 0;

}

原文地址:https://www.cnblogs.com/philippica/p/4092685.html