YT新人之巅峰大决战04

Problem Description

Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

Input

The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.

Output

You have to print a line in the output for each entry with the answer to the previous question.

Sample Input

11
9412

Sample Output

11
2*2*13*181
#include<iostream>
using namespace std;
int sushu(int a)
{
	int i;
	if(a==2)
		return 1;
	else
	for(i=2;i<a;i++)
	if(a%i==0)
		return 0;
	return 1;
		

}
void yunsuan(int m)
{
	int i;
	if(sushu(m)==1)
		cout<<m;
	else
	{
	for(i=m-1;i>=2;i--)
			if(sushu(i)==1&&m%i==0)
			{m=m/i;
			yunsuan(m);
			cout<<'*'<<i;
			break;}
	}


}
int main()
{
	int m;
	while(cin>>m)
	{if(m==1)
	cout<<1<<endl;
	else
		yunsuan(m);
		cout<<endl;
	
	}

  return 0;

}



原文地址:https://www.cnblogs.com/oversea201405/p/3767036.html