Wooden Sticks

Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1

Sample Output

2
1
3
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

struct T
{
    int w,l;
}a[5010];

bool cmp(T a,T b)
{
    if(a.l==b.l)  return a.w<b.w;
    return a.l<b.l;
}

int main()
{
    int cas;
   cin>>cas;
    while(cas--)
    {
        int n;
        cin>>n;
        for(int i=1;i<=n;i++) cin>>a[i].l>>a[i].w;

        sort(a,a+n+1,cmp);

        bool vis[5010]={'0'};
        int num=1;
        int w,l;
        int count=0,tt=0;

        while(tt<n)
        {
            vis[num]=1;
            tt++;
            w=a[num].w;
            l=a[num].l;
            bool flag=false;

            for(int i=num+1;i<=n;i++)
            if(!vis[i]&&a[i].l>=l&&a[i].w>=w)
            {
                w=a[i].w;
                l=a[i].l;
                vis[i]=1;
                tt++;
            }
            else if(!vis[i]&&!flag)
            {
                flag=true;
                num=i;
            }

            count++;
        }

     cout<<count<<endl;
    }
    return 0;
}



这道题把我害的挺惨的
原文地址:https://www.cnblogs.com/oversea201405/p/3767003.html