Common Subsequence

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

Sample Input

abcfbc abfcab
programming contest 
abcd mnp

Sample Output

4
2
0
#include<iostream>
using namespace std;
	char a[2014],b[2014];
		int c[2014][2014];
int main()
{
	int i,j,n,m;

	while(scanf("%s%s",a,b)!=EOF)
	{
		n=strlen(a);
		m=strlen(b);
	//	cout<<a<<endl;
	//	cout<<b<<endl;
		for(i=0;i<=n;i++)
			c[0][i]=0;
			for(j=0;j<=m;j++)
		     c[j][0]=0; 
			for(i=1;i<=n;i++)
				for(j=1;j<=m;j++)
					if(a[i-1]==b[j-1])
						c[i][j]=c[i-1][j-1]+1;
					else
						c[i][j]=c[i-1][j]>c[i][j-1]?c[i-1][j]:c[i][j-1];
				
			cout<<c[n][m]<<endl;
	}
return 0;
}


原文地址:https://www.cnblogs.com/oversea201405/p/3766943.html