POJ 3273 Monthly Expense (二分 最大化最小值)

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers: N and M
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400
Sample Output
500
Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题意:

将N个账款分割成M个FJ月,使得每个FJ月账款和的最大值最小。

题解:

二分查找最小值即可。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
const int maxn=1e5+5,INF=1e9+5;
int a[maxn];
int n,m;
bool check(int x)
{
	int cnt=1;
	long long cost=0;
	for(int i=0;i<n;i++)
	{
		cost+=a[i];
		if(cost>x)
		{
			cost=a[i];
			cnt++;
		}
	}
	return cnt>m;
}
void solve()
{
	int lb=*max_element(a,a+n),ub=INF;
	while(lb<ub)
	{
		int mid=(lb+ub)>>1;
		if(check(mid))
			lb=mid+1;
		else
			ub=mid;
	}
	cout<<ub<<endl;
}
int main()
{
	ios::sync_with_stdio(false);
	while(cin>>n>>m)
	{
		for(int i=0;i<n;i++)
			cin>>a[i];
		solve();
	}
	return 0;
}
原文地址:https://www.cnblogs.com/orion7/p/7743573.html