UVa 558 Wormholes(Bellman-Ford判断负环)

In the year 2163, wormholes were discovered. A wormhole is a subspace tunnel through space and time
connecting two star systems. Wormholes have a few peculiar properties:
• Wormholes are one-way only.
• The time it takes to travel through a wormhole is negligible.
• A wormhole has two end points, each situated in a star system.
• A star system may have more than one wormhole end point within its boundaries.
• For some unknown reason, starting from our solar system, it is always possible to end up in any
star system by following a sequence of wormholes (maybe Earth is the centre of the universe).
• Between any pair of star systems, there is at most one wormhole in either direction.
• There are no wormholes with both end points in the same star system.
All wormholes have a constant time difference between their end points. For example, a specific
wormhole may cause the person travelling through it to end up 15 years in the future. Another wormhole
may cause the person to end up 42 years in the past.
A brilliant physicist, living on earth, wants to use wormholes to study the Big Bang. Since warp
drive has not been invented yet, it is not possible for her to travel from one star system to another one
directly. This can be done using wormholes, of course.
The scientist wants to reach a cycle of wormholes somewhere in the universe that causes her to end
up in the past. By travelling along this cycle a lot of times, the scientist is able to go back as far in
time as necessary to reach the beginning of the universe and see the Big Bang with her own eyes. Write
a program to find out whether such a cycle exists.
Input
The input file starts with a line containing the number of cases c to be analysed. Each case starts with
a line with two numbers n and m. These indicate the number of star systems (1 ≤ n ≤ 1000) and
the number of wormholes (0 ≤ m ≤ 2000). The star systems are numbered from 0 (our solar system)
through n − 1 . For each wormhole a line containing three integer numbers x, y and t is given. These
numbers indicate that this wormhole allows someone to travel from the star system numbered x to the
star system numbered y, thereby ending up t (−1000 ≤ t ≤ 1000) years in the future.
Output
The output consists of c lines, one line for each case, containing the word ‘possible’ if it is indeed
possible to go back in time indefinitely, or ‘not possible’ if this is not possible with the given set of
star systems and wormholes.
Sample Input
2
3 3
0 1 1000
1 2 15
2 1 -42
4 4
0 1 10
1 2 20
2 3 30
3 0 -60
Sample Output
possible
not possible

题意:

问一个教授能不能利用虫洞回到过去(还是从这个虫洞出来就到达了过去),给你虫洞形成的有向图,问教授能否回到过去。

题解:

说白了就是让你判断是否存在负环。有向无环图中用Bellman-Ford算法求解单源最短图问题,最短路不会经过同一个顶点两次。反之,如果存在负圈,那么第N次的循环也会更新最短路。

贴上一个Q&A:

考虑:为什么要循环V-1次?
答:因为最短路径肯定是个简单路径,不可能包含回路的,
如果包含回路,且回路的权值和为正的,那么去掉这个回路,可以得到更短的路径
如果回路的权值是负的,那么肯定没有解了
图有n个点,又不能有回路
所以最短路径最多n-1边
又因为每次循环,至少relax一边
所以最多n-1次就行了

#include<iostream>
#include<cstring>
using namespace std;
const int maxn=2005;
int d[maxn];
int n,m;
struct edge
{
	int from,to,cost;
}es[maxn];
bool find_negative_loop()
{
	memset(d,0,sizeof(d));
	for(int i=0;i<n;i++)
		for(int j=0;j<m;j++)
		{
			edge e=es[j];
			if(d[e.to]-d[e.from]>e.cost)
			{
				d[e.to]=d[e.from]+e.cost;
				if(i==n-1)
					return true;
			}
		}
	return false;
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		cin>>n>>m;
		for(int i=0;i<m;i++)
		{
			cin>>es[i].from>>es[i].to>>es[i].cost;
		}
		if(find_negative_loop())
			cout<<"possible"<<endl;
		else
			cout<<"not possible"<<endl;
	}
	return 0;
}
原文地址:https://www.cnblogs.com/orion7/p/7704043.html